Feedback on the Dell Inspiron 7590

Asked by Kristiyan Katsarov on 2020-03-05

I am using a new version of the Dell Inspiron 7590 with 4K display and I7 9750H - however on a fresh install of Ubuntu (18.04 LTS or 19.10) the microphone does not work as well as the 3.5mm jack. Am not sure if the certified model is the same as mine, issue page - https://askubuntu.com/questions/1213271/microphone-does-not-work-on-new-dell-inspiron-7590

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2020-03-21
Last reply:
2020-03-24
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Chris Wayne (cwayne18) said : #2

Hi Kristiyan,

Sorry to hear able your audio issues. May I please ask you to try and run the OEM-OSP1 kernel on your device? The 7590 was certified with that specific kernel, which may have provided audio fixes. To get this kernel, please run `sudo apt update && sudo apt install linux-oem-osp1`. Please give that a try and let me know if it helps.

Thanks!
Chris

Chris Wayne (cwayne18) said : #3

This issue is not yet solved

Anthony Wong (anthonywong) said : #5

Hi Kristiyan,

We recently have this bug: https://bugs.launchpad.net/ubuntu/+source/alsa-lib/+bug/1859754, and it has just been fixed in alsa-lib. Can you update to alsa-lib 1.1.9-0ubuntu1.2?

Thanks,
Anthony

Aidamir Lovpache (aidamatrix) said : #6

Hi everyone. I just have installed 20.04 on my dell vostro 7590 i7 9750H . Microphone is working fine, but there is no sound in headphones. So when I plug my headphones it does detect automaically and show in setttings, but no sound. When trying to use various alsamixer switches I discovered that changing the setting 'Input Source',0 does the magic:

eagle:~$ amixer get 'Input Source',0
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Headphone Mic' 'Headset Mic'
  Item0: 'Headphone Mic'

eagle:~$ amixer set 'Input Source',0 'Headset Mic'
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Headphone Mic' 'Headset Mic'
  Item0: 'Headset Mic'

It seems that in the alsa configuration, the map controls are incorrectly matched.
Thanks.

Can you help with this problem?

Provide an answer of your own, or ask Kristiyan Katsarov for more information if necessary.

To post a message you must log in.