Feedback on the Lenovo ThinkPad X1 Extreme 2nd Gen

Asked by VINCENT on 2020-02-23

I have tried installing Ubuntu 18.04.4 on to my new Lenovo x1 extreme gen2. but it hangs so much its annoying.
It hangs when i login,
It hangs when i want to kill an application
it hangs when i want to shutdown.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Solved by:
VINCENT
Solved:
2020-02-24
Last query:
2020-02-24
Last reply:
VINCENT (sircenty) said : #1

issue resolved. the nvidia graphics card has to be blacklisted after installation

Chris Wayne (cwayne18) said : #2

Hi Vincent,

Sorry to hear about the issues you've been seeing, but glad to see they've been resolved. Before you'd blacklisted nvidia, were you using the proprietary drivers? If so, do you recall which version you'd been running?

VINCENT (sircenty) said : #3

Hi,

It was Nouveau that had been selected. But the highest on Nvidia was version 435

Chris Wayne (cwayne18) said : #4

Hi Vincent,

Thanks again for the feedback! I think for this particular device the proprietary drivers are necessary (as they are preinstalled on the factory image). I'll make sure to add a note to the certificate making this clearer. Sorry again for your troubles but thank you for the feedback.