Feedback on the Dell Precision 7920 Tower

Asked by aspirell

my computer is the dell t7920, with sliver 4114*2, 64G memory, C612 motherboard and RTX2080TI.

But when I install the ubuntu 16.04, I have to add the parameter acpi=off in grub, otherwise I can't enter the setup, and the screen was black . After installing the ubuntu and the driver of RTX2080TI, I still need to add the parameter acpi=off in grub, otherwise I can't boot into the system.

My question is simple, what does setting the parameter acpi=off actually do?And more importantly does repeatedly booting with acpi=off damage or harm the computer in anyway?

how can i do to solve this porblem? thank you

Question information

English Edit question
Ubuntu-Certification Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Jeff Lane (bladernr) said :

Setting acpi=off disables the ACPI system completely. ACPI (Advanced Configuration and Power Interface) is the system that describes hardware to the operating system to let the OS understand what hardware is present and to properly configure it, controls hardware actions such as the dynamic speed fans, the power button behavior, system sleep states, optionally to control frequencies of CPUs and helps to identify some system capabilities.

There are several acpi options you could try. "off" completely disables the ACPI system, but other options only disable parts of it. See this link for info:

You could try one of the many acpi options to only turn off specific features and just keep trying until you find one that allows you to boot successfully without completely disabling acpi.

That said, acpi=off is also a valid means to boot as well. The trade off is that things like hyperthreading and power conservation may not work. You could see the computer heating up more than usual if it uses variable speed fans, and you may not be able to do certain power-off functions, specifically, if you do a 'shutodwn -h now' or 'poweroff' the OS won't be able to actually power down the system at the end of the shutdown sequence, so you'll have to manually press the power button to power down fully.

There should be no inherent harm in disabling this, either partially or fully.

Revision history for this message
aspirell (aspirell) said :

is there any other solutions to deal with it?
such as installing the other edition of ubuntu(16.04.1 or 18.04)?
or installing the another edition of the driver of RTX2080TI?

Revision history for this message
Jeff Lane (bladernr) said :

The only other thing you could try is install the nVidia driver (the proprietary one from nVidia). You can get this from nVidia, or the version in the graphics-drivers PPA[1], and make sure you're running this and NOT the open source nouveau driver.

You'll have to leave the acpi=off to do the install, then install the nVidia driver, reboot and remove acpi=off to see if that resolves it.

Can you help with this problem?

Provide an answer of your own, or ask aspirell for more information if necessary.

To post a message you must log in.