T590 SD Card reader not working|

Asked by Alex on 2020-02-04

Hi friends. Im not privy to all the criteria on calling a box "certified", but ive been going round and round trying to get the SD card reader on the Lenovo t590 to work with a fast 128GB card and it just does not fly. It works under windows fine albeit some drivers have to be updated and it is reported in kernel 5.x as not working for fast cards.

Im sure the kernel hackers will get around to it eventually. I will report it to lenovo as well, as they tout their stuff to be linux compatible and should press Genesys to work in a propper linux driver. Just thought i should also let you guys know.

Thanks

lspci -vv Info:
 01:00.0 SD Host controller: Genesys Logic, Inc Device 9750 (rev 01) (prog-if 01)

Dmesg after card insertion:

[194830.940790] mmc0: 1.8V regulator output did not became stable
[194831.176977] mmc0: error -110 whilst initialising SD card

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2020-02-04
Last reply:
2020-02-10
Chris Wayne (cwayne18) said : #1

Hi Alex,

Thanks for taking the time to give us this feedback. SD/SDHC is in fact part of the Certification criteria, and these tests did pass during our QA run. May I ask if you're using the pre-installed image or stock Ubuntu 18.04 (or 19.04/19.10)? For curiousity sake, have you been able to use any other SD cards in the system?

Thanks
Chris

Alex (elfatherbrown) said : #2

Sorry to have taken so long. Yes, I remember a smaller 16 gb card worked okay. The one I prefer, for obvious reasons, is a Lexar 633x 128GB MicroSDXC UHS-I Class 10 device. Come to think of it, im not sure it even should work on t590 for any reason except it used to work well with my mbpro 2016 on osx (havent tested it on any linux), and I would think this recent lenovo should carry a good-enough-for-this-card reader. Will check on that too.

Thank you for your response and patience.

Alex (elfatherbrown) said : #3

Ah. And on what Ubuntu im using: downloaded from ubuntu. The t590 does not ship with ubuntu in my country.

Can you help with this problem?

Provide an answer of your own, or ask Alex for more information if necessary.

To post a message you must log in.