Touchscreen on the Lenovo ThinkPad L390 does not work

Asked by Donatas on 2019-09-27

I have Lenovo ThinkPad L390 with touchscreen and it works fine on Windows, but not on Ubuntu. I've bought this laptop trusting the Ubuntu certification, because Canonical-tested laptop included touchscreen as well, but this failed me. I've tried Ubuntu LTS 18.4 and 19.4.

Other info:
- `xinput` is showing touchscreen: "Raydium Touchscreen id=10 [slave pointer (2)]"
- if I list device props using `xinput list-props 10`, I see device: `Device Node (277): "/dev/input/event9"`
- `cat /dev/input/event9` does not produce anything
- `xinput --test-xi2 --root` does not produce any touchscreen events, even though events from other devices are successfully shown

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2019-10-20
Last reply:
2019-10-22
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Donatas (donce-lt) said : #2

I've not managed to solve this yet and I'm not the only one impacted by this: https://forums.lenovo.com/t5/Ubuntu/Touchscreen-on-the-Lenovo-ThinkPad-L390-using-Ubuntu-does-not/td-p/4537511

Donatas (donce-lt) said : #3

In addition to LTS 18.4 and 19.4, I've also tried it with 19.10 and it doesn't work as well.

Po-Hsu Lin (cypressyew) said : #4

Hi,
please open a bug report with "ubuntu-bug linux" command, which will collect vital hardware information (like the device id) for it.
Thanks
FAQ #2193: “XXXX is broken, I need to file a bug”.

Can you help with this problem?

Provide an answer of your own, or ask Donatas for more information if necessary.

To post a message you must log in.