Feedback on the Lenovo ThinkPad X1 Extreme - Padme

Asked by Lê Quang Tâm on 2018-12-08

Dear Ubuntu,

I want dual boot (win 10 and ubuntu) on my thinkpad x1 extreme, win 10 is pre-installed on it and now i want to instal ubuntu along with win 10.

The problem is when i tried to boot ubuntu by USB drive, the system usually hang, i tried it several times, sometimes it works then it restart to complete the installation then it hang again.

I really need to use ubuntu. Could you help me this problem.

Thank you in advance,

Best regard,

Quang Tam Le

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2018-12-08
Last reply:
2018-12-19
Jont Allen (jontalle) said : #1

I think you and I have exactly the same problem. Test the USB stick to see if its getting a port:2 error. Instead of booting, take the last option, to test the USB filesystem. Mine sometimes works, but typically fails half way throught the test, and then says there is a hardware error on the USB drive. This is not the case as the USB works in my Thinkpad X260.

Jont Allen (jontalle) said : #2

Today I tried to boot the ubuntu boot drive off the USB-C, and I get the same error.

In my opinion, and some testing, it seems clear that the ubuntu dirvers for the USB-A and USB-C are broken. The ports work with windows (I have not tested a bootable windows USB, only a RW memory stick), but both USB-A and C are giving port 2 errors
when trying to boot from the USB, with the linux boot drive.

I then went to Best Buy and tried to boot another brand of laptop from the Ubuntu boot drive, and that gave the same error.

More on this tomorrow, as I learn more.

Po-Hsu Lin (cypressyew) said : #3

Hello folks,

Which Ubuntu that you're trying? Can you give 18.04.1 or 18.10 (or even the daily-build version - Disco Dingo) a try?
Thanks

Jont Allen (jontalle) said : #4

I have progress on this front. I tried the Fedora distribution and it booted fine. I downloaded several of the ISO images from
https://dl.fedoraproject.org/pub/alt/live-respins/
Not all worked perfectly, but all booted off of the USB perfectly.

To make the usb I used dd to copy the ISO image to the USB memory stick.
Something like the following:
  sudo dd status=progress bs=100M if=F29-MATE-x86_64-20181213-Live.iso of=/dev/sdb
Then I booted the USB and it tested the image ISO, and then booted linux.

Now I have a new problem: suspend appears to work but the system fails to resume. It simply hangs during the resume process.

Any ideas on how to fix this?

I found the following posting helpful:
https://www.reddit.com/r/thinkpad/comments/9fos6i/x1_extreme_does_not_like_linux/
scroll down to the post by
tom91136
10 points ·
3 months ago

Machine arrived today, updated BIOS to 1.09(before this a soft lockup would occur when booting). I've tried booting Ubuntu 18.04 LTS and it booted into live desktop after switching around USB ports. For some reason, one USB port would give me errors about the controller being bad.
.....
Lots of useful stuff here. Important are changing the video in the bios: set your graphics to discrete.
Important:
Remember to update all packages again
    mine would not resume from sleep until I updated my kernel to 4.18.5-200.fc28.x86_64

Jont Allen (jontalle) said : #5

One suggestion is that the swap space is too small. My installation of Fedora has no swap space, so if the resume is being saved in the swap partition, that would be an excellent reason for it to fail. I would suggest setting up a swap partition, to solve the resume problem. I'm going to tray this approach at some point. So far its simply a comment.

Jont Allen (jontalle) said : #6

the swap space is not the issue re suspend. First Fedora has a swap space. Its not a partition on the hard drive,
its a block device. My system has 16 BG of memory and the block device is 8GB, so there is the outside chance that suspend is trying to save 16G in an 8G partition. Any thoughts on this anyone? I'm seeing this as a remote reason for the suspend failure to resume.

Po-Hsu Lin (cypressyew) said : #7

Hi Jont,

Thanks for sharing, another possible cause to your suspend issue might be the graphic driver. Try the proprietary driver for your discrete card (if available) to see if it helps.

For issues like these, I would encourage you to go to the community (https://ubuntuforums.org/ and http://askubuntu.com ) or just open a bug with Ubuntu by using command "ubuntu-bug linux" in a terminal (ctrl + alt + t) as this place is more like a place for certification itself.

Thanks!

Jont Allen (jontalle) said : #8

A short message update. I now have everything working on the X1-Extreme think pad. Suspend/resume, the F5/F6 graphic intensity control, and everything else as far as I know. The instructions from redit are correct, but leave out some important details. The claim that this works is true. I'll post more details once I know how. Here are some additions to the redit instructions:
----------------------------------------------------------------------
Disabling the discrete graphics card: Exteded method (JBA)
----------------------------------------------------------------------
* Have a second computer ready for troubleshooting.
  Go to this tutorial and jump to section 2.6 Disable nouveau
Follow all of sections 2.6.1 and 2.6.5
 Following step 2.6.5:
>> systemctl set-default graphical.target

reboot into setup (BIOS) & switch to [Hybrid Graphics] (otherwise you won't have a desktop)
reboot to your OS
   1) Verify that F5- and F5+ now work to change brightness of screen
   2) Verify nouveau is disable by doing dmesg | grep nouveau (nouveau should not appear)
   3) Verify that suspend/resume now works! (YES)

Install powertop/tlp and make sure to enable power management for video card
I would say SOLVED, for now.

Can you help with this problem?

Provide an answer of your own, or ask Lê Quang Tâm for more information if necessary.

To post a message you must log in.