Feedback on the HPE ProLiant DL120 Gen9

Asked by Hector Peralta on 2018-09-13

Hello:

I've been trying to setup a Raid 5 with ubuntu server 16.04.03 on a HP DL120 G9 server, but, after installation finishes and reboots, the server displays the error, "missing boot EFI media".

- I've tried installing Raid 5 in many ways shown in diverse sources, but with the same result.
- Since I couldn't make it work, I've test to install it only in one hdd, NO Raid, and ubuntu server installs OK.
- I've been wondering if the server BIOS Configuration has to be adjusted.
- I've test to change 2 BIOS config options: enable the SATA AHCI support, and Enable/Disable the UEFI Optimized Boot option, but the result is the same changing this last option.
- Even though, I have used the Dynamic Smart Array RAID that comes with the server and installed Windows Server 2012 R2, I would really like to setup ubuntu server in it. I've been learning ubuntu in a self-taught way and have found many advantages.

Server Info
HP Proliant DL120 Gen9
HP BIOS Version = P86 v1.50 (07/20/2015)
System Memory = 32MB RAM
Server has 4 hdd's of 2TB each
SATA AHCI support = Enable
Boot Mode = UEFI Mode

I've been struggling with this installation for some time, so, any assistance will be well appreciated.

Kind regards
Héctor Peralta

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2018-09-13
Last reply:
2018-09-13
Jeff Lane (bladernr) said : #1

As the certification note explains for 16.04, Dynamic Smart Array was disabled:

HP Dynamic Smart Array
System is certified with Dynamic Smart Array disabled.

To disable Dynamic Smart Array:
* Press F9 to boot into RBSU
* Navigate to System Options -> HP Dynamic Smart Array B320i and select disable
* Go to System options -> SATA Controller options and select Legacy SATA or AHCI
* Reboot the machine and now you will be able to install the OS.

You may find some community info on enabling DSA on these systems, however, they're not technically supported.

I have disable the DSA and enable the SATA controller within the BIOS setup, but still does not solve the problem.
After finishing Raid 5 server installation and rebooting, I'm still getting the "missing boot EFI media" error.

Jeff Lane (bladernr) said : #3

Please forgive my asking, but if you have disabled Dynamic Smart Array, what are you using to configure RAID? And can you disable EFI and do it entirely in Legacy mode?

Also, please see the attached FAQ for info on support options that may help a bit better than this.
FAQ #1945: “Where can I get help or technical support?”.

Can you help with this problem?

Provide an answer of your own, or ask Hector Peralta for more information if necessary.

To post a message you must log in.