Feedback on the Dell G7 7588 - Firestar B 15

Asked by Daryl on 2018-07-31

Installer for Ubuntu 18.04.1 assumes the laptop to be bios based and not efi based. Installer fails to install grub near end of configuring hardware. Tried yannubuntu ppa:boot-rec. It reported no efi partition and walked through getting one in there. Still failed as shimx64 never made it to fso. Dells own os-recovery tool installed windows on the wrong internal hard drive so I think there are bios updates that need to roll. Tried booting with nvme_load=YES. either way the ssd shows up but can't install grub to either sda or sdb. Bios is set per dells recommendations for installing Ubuntu. No tpm, no safe boot, thorough mode on hardware scan, legacy rooms enabled and ahci set on sata controller. Tried shutting down drives in bios but installer fails to see installed system in all cases. Also failed to install grub in both gpt and MS dos based partition tables. Not sure what else to try other than to ask how dell installed?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2018-07-31
Last reply:
2018-08-10
Po-Hsu Lin (cypressyew) said : #1

Closing this issue, as the report has provided a solution.
https://answers.launchpad.net/ubuntu-certification/+question/671450
Thanks, Daryl!

Can you help with this problem?

Provide an answer of your own, or ask Daryl for more information if necessary.

To post a message you must log in.