Feedback on the Lenovo ThinkServer RD350 (Intel v4 Series)

Asked by Jamey on 2017-06-30

I just bought 2 of these servers in hopes of installing 16 lts but it appears I can't even get 14 to install. Is there any further advice? Otherwise, This server is not compatible with Ubuntu 14 or 16 or 17.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Jeff Lane (bladernr) said : #1

The RD350 was tested and certified for 14.04.4. It was deployed via MAAS 1.9.1+bzr4543-0ubuntu1~trusty1 and was installed using the 4.2.0-27 kernel.

It is difficult to offer advice, however, with no information to go on. Please provide more detail about the issues you are experiencing with installing Ubuntu, including WHICH Ubuntu you are installing, how you are installing it, what problems you are facing when installing.

I will do what I can, but this is not a technical support venue, so I'd also ask that you check out the attached FAQ for more information about places to obtain support for Ubuntu.
FAQ #1945: “Where can I get help or technical support?”.

Jeff Lane (bladernr) said : #2

waiting on reply

Jamey (jcyphert) said : #3

I appreciate your willingness to help.

I installed both of these versions, neither worked.
https://certification.ubuntu.com/hardware/201603-21483/
https://certification.ubuntu.com/hardware/201412-16320/

I also tried installing the current 16 LTS and the current release of 17.

The results of each:

Configured the bios to use RAID5 and UEFI. I also disabled secure boot as I read that might cause problems. It would go thru the setup as it should. It even detects their is a raid car and asks (twice) if I would like to install the drivers. I choose yes both times. everything goes well until it tries to find the installation media. When it gets to this step it only offers the USB drive as an installation option. I tried this multiple times rebuilding the hardware array in 1, 0 and 5. Same results. I tried switching to legacy only mode rather than UEFI, Same thing.

I tried installing with no raid active. Everything installs as it should until I get to the Grub installer. It fails to install every time using 3 different brands of USB drives and all the OS's mentioned above. Non of them will install. I tried switching to IDE, AHCI legacy only, uefi. Pretty much every configuration you can think of in the BOIS, I have tried.

ALSO, I bought two of these servers and it does the exact same thing for each of them so I'm fairly confidant it's not bad hardware.

I'm open to trying anything you suggest.

Jamey (jcyphert) said : #4

GRUB message

grub boot loader failed to install
'grub-efi-amd64-signed'

Jamey (jcyphert) said : #5

waiting on reply

Jeff Lane (bladernr) said : #6

Are you using built in SATA RAID, or an external RAID controller? Turn off onboard RAID and see what happens.

The Certified models used a PCIe based LSI Raid Controller, not the onboard BIOS RAID.

Jamey (jcyphert) said : #7

I already tried the install with raid disabled (see post #3). It appears a majority of my problems were stemming from using USB installation media rather than CD. Now that I rigged up a cd drive it will install just fine without RAID.

I am trying to us the built in RAID chip as I paid $150 extra to enable raid5. That's a real disappointment if I need to buy another PCIe raid card.

Jeff Lane (bladernr) said : #8

Ahhhhh... OK. Sorry, I missed the part about no RAID. I'd say file a bug for the installer, but to be honest, I've complained about that for a long time. I see what the issue is now.

So to summarize, with RAID enabled, you see no storage except for the USB stick (in other words, it sees a RAID device, asks you to install drivers, and then doesn't show you any disks to format and install to). Best I can offer is to file a bug there against the kernel, but to be honest, my own personal experience with onboard RAID and Linux in general has never been good. The only hardware RAID I've ever seen work pretty much all the time is an external RAID card (and in fact, I don't believe any of our partners have ever even tried certifying using onboard RAID).

And with RAID turned off, everthing works until Grub. That one is fixable... when you get to the "Where to install Grub" part, there should be an option for "Advanced" or something along those lines (Sorry, it's been forever and a day since I last did a CD or USB install). What's happening there is that your USB drive is showing up as /dev/sda, and the installer is just blindly defaulting to writing Grub to /dev/sda, hence, unbootable system.

This kinda shows how long this has been an issue (and it's really system specific, some systems do this, some do not):
https://superuser.com/questions/176050/ubuntu-server-installed-from-usb-puts-grub-on-the-usb-drive-instead-of-the-hard

but there are also some workarounds in the comments as well, including what I mentioned above about changing the grub install location in the installer.

Can you help with this problem?

Provide an answer of your own, or ask Jamey for more information if necessary.

To post a message you must log in.