Cannot successfully install Ubuntu 14.04 on Applied Micro Circuits Corp. X-Gene 2 (Server Reference Board) - Merlin

Asked by K Jelesnianski on 2017-04-04

For our research, we require to have the server running an Ubuntu distro of Linux (Red Hat came pre-installed on X-Gene 2) and have been having trouble getting to install Ubuntu 14.04 onto X-Gene2.

We have closely followed the guide here:
https://certification.ubuntu.com/hardware/201608-25047/
and following the Netboot Installation guide here:
https://help.ubuntu.com/community/Installation/Netboot

Attempting to Install Ubuntu 14.04 via PXEboot gets us to the point where the X-Gene 2, sees the DHCP server, but cannot boot and initiate the ubuntu installation.

(Traditionally the X86 architecture netboot.tar.gz image contains the file "pxelinux.0" which the client (e.g., the X-Gene 2) would download and attempt to run to initiate installation; no such file "pxelinux.0 exists on the aarch64 14.04 netboot image for Merlin)

Any suggestions or personnel that could help us resolve this issue would be greatly appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Jeff Lane (bladernr) said : #1

The instructions found here[1] should give you better information about your specific hardware. Please give them a shot. Beyond that, if you need further assistance, please refer to the linked FAQ that details the various ways you can get further technical support both from the community and from Canonical.

[1] https://wiki.ubuntu.com/ARM/Server/Install/Merlin
FAQ #1945: “Where can I get help or technical support?”.

Jeff Lane (bladernr) said : #2

One other thing, that process may or may not work with the X-Gene 2, they were based on the older X-Gene SoC, so YMMV.

Can you help with this problem?

Provide an answer of your own, or ask K Jelesnianski for more information if necessary.

To post a message you must log in.