ThinkPad L450 Ubuntu installation error

Asked by abheet on 2016-08-01

Seeking help actually I have purchased ThinkPad L450 with DOS as OS,

Now when starting the Laptop it goes to Ubuntu 14.02 LTS installation [OEM installation, only for Manufacture], and it proceed automatically, but in between the installation process , getting error message i.e popup "Failed to install grub on /dev/sda2," , and when try to choose different disk volume i.e /dev/sda/ "Hitachi 500MB" from dropdown provided, it didn't allow me to go further, and popup keep alerting i.e. not correct disk volume or size is less.

I have set BIOS
Secure booting = disabled
Fastbooting =disabled
Mode = leagcy

This is new laptop and i am trying to install Ubuntu first time that too factory provided.

Looking froward for the solution, how i can get it installed successfully.

Thanks in advance

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Solved by:
abheet
Solved:
Last query:
Last reply:
Revision history for this message
Po-Hsu Lin (cypressyew) said :
#1

Hello,
If your laptop came with DOS as its OS, why you can see the Ubuntu installation screen?
Did you make a bootable USB for it? And what version of Ubuntu that you're trying to install, 14.04.2?

You can find the installation instructions here:
http://www.ubuntu.com/download/desktop/install-ubuntu-desktop
https://help.ubuntu.com/community/Installation

If you still have issues with it, I would suggest you to visit the community for help. Links can be found in the FAQ here.

Thanks
FAQ #1945: “Where can I get help or technical support?”.

Revision history for this message
abheet (abheet-jamwal) said :
#2

Hi Lin,

Thanks for replying, i saw Ubuntu OEM installation screen, Because it is provided by Lenovo with Ubuntu 14.02 in thinkpad L450

http://www.ubuntu.com/certification/hardware/201501-16541/

But while installation it gives fatal error i.e " unable to install Grub on /dev/sda2/" .

To fix it i have tried to create partition on hdd with Ubuntu Live session (i.e. Try Ubuntu without installing), actually i have mounted /dev/sda1/ with disks utility i.e mark * to it.

which messed up booting process,now even when i am trying to boot Ubuntu 16.01 with Usb, it open initrams console.

Can you please help me to fix this ??

Thanks,
 --Abheet

Revision history for this message
Po-Hsu Lin (cypressyew) said :
#3

Hello,

Sorry I got a little bit confused, so your system came with only DOS on it? Or it came with Ubuntu 14.04 (or 14.04.2?) installed on it?

Thanks

Revision history for this message
abheet (abheet-jamwal) said :
#4

Lin,

Yes my system came with Pre-installed with Ubuntu 14.04 LTS OEM setup, but unfortunately i have deleted the partition.

Link : http://www.ubuntu.com/certification/hardware/201501-16541/

And now after partitioning hdd, installed Ubuntu 16.01 LTS.

Actually got frustrated after not getting any support from Lenovo Support center regarding the Ubuntu OEM installation error. Then i decided to do it in my own way.

Only thing i have missed is! i didn't created the recovery disk of existing pre-installed Ubuntu OEM setup, which come with factory pre-installaton setup.

Anyways Thanks for you help.

AJ