Feedback on the Dell Latitude 3470 - Loveland 14 SKL

Asked by Balakrishna on 2016-04-04

Hi,

I have a laptop received from Dell Latitude 3470 with Ubuntu pre-loaded but the installer is crashing midway.
http://www.ubuntu.com/certification/hardware/201507-18784/

Specifications of my laptop:
Ubuntu Linux 14.04 LTS SP1 64-bit
Intel Core i7-6500U Processor Base, NVIDIA GeForce 920M Discrete Graphics
Please check Tech Specs for full info (http://www.dell.com/in/business/p/latitude-34x0-laptops/pd)

Is there any mismatch in hardware that Dell has provided? Any help is appreciated

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Solved by:
Shih-Yuan Lee
Solved:
2016-04-08
Last query:
2016-04-08
Last reply:
2016-04-08
Balakrishna (krishnavad) said : #1

Hi,

Looking at the other posts, I can think the solution to this issue is to contact OEM to get the custom ubuntu ISO image.
Why can't the Dell guys make these custom ISO available publicly atleast on their websites?

I understand that the next LTS release is slated to be on 21st April,2016. Any chance that these custom images will go into this release?

Thanks

Pierre Equoy (pieq) said : #2

Hi,

just to confirm: you got a laptop from Dell, it came with Ubuntu pre-loaded on it, but the installation fails and you cannot use it?

At what step does the installation crash exactly?

If your laptop came pre-loaded with Ubuntu, I suggest you contact Dell hotline directly.

As for your question regarding the next LTS release: the version available on ubuntu.com is the generic version. The version pre-installed by Dell on their system is a similar version with some Dell-specific tools added (for instance, a customized Dell recovery tool).

Balakrishna (krishnavad) said : #3

Hi,

Thanks for your response.

Yes, I got the laptop from Dell with Ubuntu pre-loaded on it.

Once I power ON the machine, I can configure the following in sequence but afterwards it crashes
 language -> timezone -> user settings (username, password, laptopname) -> opt for backup of recovery disk

I see from here http://www.ubuntu.com/certification/hardware/201507-18784/ that the ubuntu is pre-loaded by manufacturer. My question was whether for this particular hardware, will generic version in the next release work? I understand that all these OEM images are sometime merged into the generic version. That's why the question.
As you know, response from Dell is very bad regarding this, I was just wondering if I can wait and rely on the next release to install in this machine.

Thanks

Pierre Equoy (pieq) said : #4

Hi,

I don't think there is a plan to merge the Dell OEM version into the generic one.

What crashes exactly? Is there an error message? Does the screen freeze?

Balakrishna (krishnavad) said : #5

Hi,

There is no error message as such to identify the issue. Instead there are these dialog boxes with message

"We are sorry, the installer crashed . After you close this window, we will allow you to file a bug report using the integrated bug reporting tool. This will gather the information about your system and the installation process."
When I close that window another dialog appears which says, "The problem can't be reported. This is not an official ubuntu package. Please remove any third party package and try again"

Thanks

Howy (howy1979) said : #6

@Balakrishna,

Can you take a picture for the issue?
Thanks!

I am trying to reproduce the issue on my unit now.

Balakrishna (krishnavad) said : #7

Sorry,

I missed your post...how can I post the picture. If you can give me your email, I can send you the series of screenshots.

Thanks

Po-Hsu Lin (cypressyew) said : #8

You can paste it to somewhere like http://imgur.com and paste the link back here.

Balakrishna (krishnavad) said : #9

Thanks,

Pls find the link http://imgur.com/T9FJe7A

Pierre Equoy (pieq) said : #11

Thanks!

We're investigating this issue and will come back to you soon.

Shih-Yuan Lee (fourdollars) said : #12

@Balakrishna,

Could you help to extract the data from the recovery partition for us?
You can download the image from http://cdimage.ubuntu.com/daily-live/current/ and make a bootable media such as DVD or USB stick.
And then booting up the Ubuntu live system from it to extract the data from the recovery partition.
You may need to upload the whole content to some cloud drive for us to download and investigate this problem.

BTW, the crash you met is about dell-recovery, it is not covered by Ubuntu Certification and it is majorly maintained by Dell.

Pierre Equoy (pieq) said : #13

Balakirshna,

in order to create a bootable disk from the Ubuntu image you can download from ubuntu.com, you can follow one of these guides:

- How to create a bootable USB stick on Ubuntu <http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-ubuntu>
- How to create a bootable USB stick on Windows <http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-windows>
- How to create a bootable USB stick on Mac OSX <http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-mac-osx>

To extract the data from the recovery partition, Shih-Yuan is going to provide a bit more information later on.

Balakrishna (krishnavad) said : #14

Thank you for the update.

Can you suggest any guidelines on how to extract the data from the recovery partition after booting from the USB ?

Thanks

Balakrishna (krishnavad) said : #15

Sorry, I missed your earlier post, creating a bootable disk now. I shall extract the data once I receive the guidelines from Shih-Yuan.

Thanks

Shih-Yuan Lee (fourdollars) said : #16

1. When you see http://imgur.com/XOLRUoU, please select "Try Ubuntu without installing" and enter it.

2. Plug in another USB storage and make sure it has at least 4GB free space.

3. After you see http://imgur.com/v5n66pH, left click on the 'OS' icon in left panel as http://imgur.com/m1RBKqu did.

4. Selecting all files http://imgur.com/bqCQVFN

5. Right click any selected icon to click 'Compress...' in the popup menu as http://imgur.com/OOVrexG did.

6. Using .tar.xz filename extension and choosing the right location of your USB stick to create the content as http://imgur.com/1VCoyQT did.

7. Shutdown the system from the top right menu as http://imgur.com/MHNBVP4 did.

Then you can use another computer to upload OS.tar.xz into some kind of cloud storage service such as https://mega.nz and share us the download link.

Balakrishna (krishnavad) said : #17

Hi Guys,

Please find the data from the recovery partition at
https://mega.nz/#!QN0nVQRC. Please let me know in case of any missing information.

Thanks

Shih-Yuan Lee (fourdollars) said : #19

@Balakirshna,

I didn't extract the right content from 'OS' the recovery partition.

Shih-Yuan Lee (fourdollars) said : #20

What you extracted is the content from the USB drive.
You need to redo the whole process above and find the correct recovery partition.

Balakrishna (krishnavad) said : #21

Hi Shih-Yuan,

I followed all the steps. Please let me know what can I do further.

Thanks

Shih-Yuan Lee (fourdollars) said : #22

@Balakirshna,

OK, please follow the step 1 & 2 of comment #16.
When you see http://imgur.com/v5n66pH, pressing Ctrl+Alt+T to open a terminal.
And then executing `sudo parted -l`, taking a screenshot by 'Print Screen' key, saving and uploading the image.
The image looks like http://imgur.com/UJL56G1.

Balakrishna (krishnavad) said : #23

Hi,

I am not able to boot from USB now..Laptop is freezing at the Dell logo symbol.

Thanks

Shih-Yuan Lee (fourdollars) said : #24

You may need to redo comment #12 & #13 again.
Please format the USB stick in the beginning.

Balakrishna (krishnavad) said : #25

Hi,
Please find the screenshot for "sudo parted -l" at http://imgur.com/iDfZ3B2.

Thanks

Shih-Yuan Lee (fourdollars) said : #26

And then execute `sudo mount /dev/sda2 /mnt && nautilus` and use it to extract the data from /mnt just like comment #16.

Shih-Yuan Lee (fourdollars) said : #27

Sorry, there is a typo of comment #26, the command should be `sudo mount /dev/sda2 /mnt && nautilus /mnt`.

Balakrishna (krishnavad) said : #28

When executing "sudo mount /dev/sda2 /mnt && nautilus /mnt", I am getting
mount: /dev/sda2 already mounted or /mnt busy
mount: according to mtab, /dev/sda2 is mounted on /cdrom

Shih-Yuan Lee (fourdollars) said : #29

Then you can execute `nautilus /cdrom` and extract the data from it instead.

Balakrishna (krishnavad) said : #30

Hi Shih-Yuan,

Sorry for the delay, please find the file at
https://mega.nz/#!0JMREKjB!d7WEDbBFGopDdDbp5qVgXPpaEhQyJ0NiX7DfadqfDyo

Please let me know if I missed something.

Thanks

Best Shih-Yuan Lee (fourdollars) said : #31

Hi Balakirshna,

I found the filesystem.squashfs that you provided is different from what we provided to Dell.

01b6395f17c93a826967b7df17bbdcb3 ./casper/filesystem.squashfs <= Yours
246e33fe3d79d9a5cd0c5f5671edd6d8 ./casper/filesystem.squashfs <= What we provided to Dell.

It seems something wrong in their factory process.
Please contact Dell to get the support.

Balakrishna (krishnavad) said : #32

Hi Shih-Yuan,

Thanks a ton for your effort, this clears where the system is crashing. Lastly, I have a question. With this, it will be more clear.

I see couple of differences for the hardware/firmware specified in http://www.ubuntu.com/certification/hardware/201507-18784/ with my laptops. Could that be a reason for this crash?

Certified hardware/firmware Dell provided hardware in the laptop
1. Bios: Dell: 00.03.33 (UEFI) Bios Version: 1.1.2
2. Graphics: nVidia GK208M [N16V-GM] nVidia® GeForce® GT920M

Thanks

Balakrishna (krishnavad) said : #33

Sorry formatting issue, tab space not working.

Certified hardware/firmware (http://www.ubuntu.com/certification/hardware/201507-18784/)
1. Bios: Dell: 00.03.33 (UEFI)
2. Graphics: nVidia GK208M [N16V-GM]

Dell provided hardware in the laptop
1. Bios Version: 1.1.2
2. Graphics: nVidia® GeForce® GT920M

Thanks

Shih-Yuan Lee (fourdollars) said : #34

No, I think the root cause of the crash is because Dell's factory process didn't include the right filesystem.squashfs.
Regarding different firmware/hardware, they are just not covered by Ubuntu Certification but you should not have the crash if you have the right filesystem.squashfs.

Shih-Yuan Lee (fourdollars) said : #35

That's to say, we can not guarantee that your firmware/hardware can work well because they are not covered by Ubuntu Certification.

Balakrishna (krishnavad) said : #36

Thanks a lot to you and your team for the effort.

I am in touch with dell regarding this but they are very bad at Ubuntu support.
I would need to heighten my effort of complaints for them to react positively.
Till now the effort from them had been very narrow.
Their Linux forums are also not very active.

This solved my issue. Marking the issue as "Problem Solved"

Best Regards

Balakrishna (krishnavad) said : #37

Thanks Shih-Yuan Lee, that solved my question.

Balakrishna (krishnavad) said : #38

Hi Shih-Yuan,

Will re-install of Ubuntu 16.04 work on this machine? Can you please suggest any alternative instead of depending on Dell support?

Thanks

Shih-Yuan Lee (fourdollars) said : #39

Hi Balakrishna,

We don't have Dell Latitude 3470 - Loveland 14 SKL with your firmware and graphics so we can not tell if Ubuntu 16.04 works on it or not.
It should work but we can not guarantee that.

Shih-Yuan Lee (fourdollars) said : #40

Hi Balakrishna,

We contacted Dell for your problem.

They are asking what language you selected.
I am also wondering what timezone you used.

Balakrishna (krishnavad) said : #41

Hi Shih-Yuan,

Thanks for contacting Dell in this regard. I have selected language as English and timezone - Kolkata.
http://imgur.com/vJR7xgc
http://imgur.com/owN7TgE

Best Regards

Shih-Yuan Lee (fourdollars) said : #42

Hi Balakrishna,

Could you try to use 'New York' as your timezone to see if it still crashed?

Balakrishna (krishnavad) said : #43

Hi Shih-Yuan,

Fed up with Dell Technical support, I have formatted my disk completely and installed Ubuntu 16.04 nightly build which is working fine. I haven't come across any issue till now.

Thanks

Shih-Yuan Lee (fourdollars) said : #44

Hi Balakrishna,

Cool. Hope you enjoy Ubuntu.

Balakrishna (krishnavad) said : #45

Thank you Shih-Yuan and your team for the excellent support that you have offered.

Best Regards