Feedback on the Dell Inspiron 3451 - Iris 14 BTM

Asked by Brian Fox on 2015-08-25

I have the Dell Inspiron 3451 14" preinstalled with Ubuntu with a 64 bit Intel® Pentium® Processor N3540. An update from about a month ago causes these machines to have a kernel panic on reboot. If I do a factory reset, it works fine, but when I run updates on the "fresh install," the problems comes back, and I don't want to damage the data I have on the recovery partition in case Canonical is able to fix this to make it work again. In the meantime, I replaced the hard drive, and tried reinstalling stock Ubuntu 14.04 64 bit, and the problem persisted. I can install 32 bit Ubuntu 14.04.03, and updates do not cause kernel panics now, but I do not have a functioning trackpad. I am not the only person with this issue. It is really quite a shame, because I bought this laptop because it came preconfigured with Ubuntu. Dell's inept customer service and technical support (based in India) has been of zero help, and caused lots of aggravation. Is Canonical aware of how badly Dell is messing up its roll-out of laptops running Ubuntu? I feel really bad for Linux newbies having to deal with this. Can I expect the 64 bit version of the OS to be fixed so it works with this hardware? Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2015-09-04
Last reply:
2015-09-04
Po-Hsu Lin (cypressyew) said : #1

Hi,
what's the version of your pre-installed system? 14.04?
What's the kernel version that's causing this issue? (Run "uname -a" in a terminal, if you can't boot into desktop, press ESC after the DELL logo on boot to enter grub, then check "Advanced Options for Ubuntu" for all available kernel versions)
Does this bug fit your situation?
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1482273
Thanks

Ray Chen (ray.chen) said : #2

Hi,
Can you please check your factory image version? follow below steps to check factory image version.

1. Press Ctrl + Alt + t to launch terminal
2. type "sudo mount /dev/sda3 /mnt", mount recovery partition to /mnt
3. type "head /mnt/bto.xml"
4. Check the line start with <iso>...............................</iso>
Could you please share the ios file name?
it should be like "dell-bto-trusty-iris-intel-A00-iso-20141128-0.iso"

I just verify this issue on fresh install with iso version A00
the kernel version was linux-image-3.13.0-38-generic
after run "Software Updater"
The kernel upgrade to 3.13.0-62 without kernel panic.
I can not reproduced this issue, please provide us more information, thanks!

Brian Fox (brianf1969) said : #3

I actually pulled that hard drive out and have it in storage now. I replaced the hard drive, and did a clean install on a never used drive with Ubuntu 14.04.03 64-bit. Everything worked properly except for that. To make the trackpad work, I typed did the following in terminal:

sudo vi /etc/modprobe.d/blacklist.conf

add this line to the end of the file:

blacklist i2c-hid

save, close, reboot

Everything works now.

Brian Fox (brianf1969) said : #4

Everything worked properly but the trackpad. I left out a thought. The fix I found online helped me solve that problem. I think the issue is not being addressed by anyone at Dell, the issue being that their customized version of Ubuntu is broken. I would have much preferred stock Ubuntu, and providing some ppa's for drivers, the way System76 does.

Po-Hsu Lin (cypressyew) said : #5

Hi Brian,
I will close this question as we're unable to reproduce the issue you encountered here on kernel 3.13.0-62 with an Ubuntu pre-installed Dell Inspiron 3451 and you're not using that anymore, it's hard to determine if there is really a bug there or if it's caused by any other softwares.

And thank you for sharing the workaround for the trackpad. You can always open a bug report for it, I have the FAQ linked here for your reference.

Cheers.
FAQ #2193: “XXXX is broken, I need to file a bug”.

Can you help with this problem?

Provide an answer of your own, or ask Brian Fox for more information if necessary.

To post a message you must log in.