Feedback on the Dell Inspiron 15 7000 Series 7548

Asked by James Calfee on 2015-02-11

The monitor can go into a flickering mode which is often and easily triggered by going into "Search your computer and online sources." It is especially bad if other applications are open like Chrome or extra features in compiz are enabled. It can go into a loop that will get so bad that one can not exit from forcing a reboot. It is not reliable.

I'll attempt to disable features in compiz to get the machine stable or look for a driver I can use. I have tried disabling (in compiz-settings-manager) "Unredirect Fullscreen Windows." Also tried increasing the "Launcher reveal Pressure."

Please let me know if you have a fix or a work-around.

Question information

Po-Hsu Lin (cypressyew) said : #1

Hello James,

Could you tell us what's the resolution you're using on your laptop? I guees it's ~4k?

Thanks

James Calfee (l-james-s) said : #2

Yes, the problem happens in 4k (3840x2160) and only happens at that resolution. That is the the max for this laptop. Anything lower is fine. I run the intel 64bit 14.04 installer (https://01.org/linuxgraphics/downloads/2014/intelr-graphics-installer-linux-1.0.7) and it said I am up-to-date.

Po-Hsu Lin (cypressyew) said : #3

Hi James,
We do encounter the same issue while trying to certify a Dell Inspiron 7548 like the one you have.
Unfortunately, we will need to wait for a fix from upstream.
I linked the bug here, I would recommend you to subscribe to it.
Cheers.

James Calfee (l-james-s) said : #4

Great, I will... FYI, it quickly degrades from just a blink to so many blinks the screen does not show at all. I have put compiz-plugins and enabled the negative plugin so that may have speed up the process. It is like the more it is used the worse it becomes. I noticed that quick tapping or dragging on the screen or even the keyboard does slow it down.

Luis Uriel (fusion-platinum) said : #5

I have the same computer and I had the same problem. I found the next:

# sudo gedit /etc/default/grub

look up "GRUB_CMDLINE_LINUX=" and add "i915.enable_ips=0" as value. (if exists something else just add)
in my case it was:
GRUB_CMDLINE_LINUX="i915.enable_ips=0"

Update grub configuration and after you can reboot the computer:
# sudo update-grub

I'm not expert and I don't understand why but it works. I hope it works for you as well as for me.

Regards.

James Calfee (l-james-s) said : #6

Could you please check upstream. I just ran updates and the problem still exists.

Can you help with this problem?

Provide an answer of your own, or ask James Calfee for more information if necessary.

To post a message you must log in.