Feedback on the HP ProLiant DL360p Gen8

Asked by Denis Vounckx


I tried to install Ubuntu 12.04 LTS 64-bit server on this model.
Installation worked fine. But after restart the server does not boot (on the console there is a message " hard disk C: not found")
I tried the note for DL360e Gen8 (being to deactivate HP smart array). But this option is not visible in the RBSU (ROM based setup).

Any idea howto continue?

Question information

German (Germany) Edit question
Ubuntu-Certification Edit question
No assignee Edit question
Solved by:
Denis Vounckx
Last query:
Last reply:
Revision history for this message
Narinder Gupta (narindergupta) said :

I believe you need to configure the logical drive as bootable volume in the samry array controller firmware as suggested by HP. We have seen this behavior when we do not configure the logical drive you are installing on as boot volume. During the system POST press F8 to configure the logical drives connected to your smart array controller. Then choose the option select boot volume and select the logical drive which you want to boot it from. Hope this will solve your issue on the system.

Revision history for this message
Denis Vounckx (denis-vounckx) said :

Thanks for the rapid response.

Found out that the server did boot when I inserted the USB stick...
Now analyzing the stick it showed a "/boot" dir with grub on it !

So it seemed grub was installed on the installation stick iso the HP drive.
Going through the install procedure again I found my mistake:
When installing grub it asks the device to have it installed on. It proposes 'sdb' but I changed this to 'sda' (as I was convinced the server drive is called 'sda'). But during installation sda is the usb stick ! Quit tricky...