Feedback on the Dell Latitude E6430 touchpad

Asked by Ben Gamari on 2012-08-03

The Alps touchpad used in the Dell Latitude E6430 is currently entirely unsupported by the kernel's alps.c driver. This means that,

* Multitouch does not work (currently on the certification blacklist)
* Vertical and horizontal scroll do not work (grey list)
* Touchstick can't be configured independently from touchpad

These ought to be noted on the certification document.

Jeff Lane (bladernr) said : #1


Wow, you certainly did your homework. However, there is some additional context necessary.

First, for now, Multitouch is on the blacklist. What that really means is that we don't test it. MultiTouch is just now becomming more widely supported in Ubuntu, and we are in the process of adding MultiTouch tests. When that process is complete, we will move Multitouch to the Greylist and begin actually testing MT and MT gestures, at least to a basic degree.

I mentioned Greylist. Your next item is a greylist item, Vertical and Horizontal scrolling. Greylist means we test it, but don't fail the machine if they don't work. In this case, we do perform a couple basic tests to check vertical and horizontal scrolling, but previously would not fail a machine on that. This too, is under review.

The touchstick thing is a different beast alltogether. And I agree with you... I have a thinkpad with the same sort of setup and there too I can't independently configure the devices, which is bad because I want the acceleration rate for the trackpoint to be slower than for the touchpad :(

Unfortunately, that's simply a limitation of the driver, IIRC, and not something we'd even test for. As long as they work, it'll pass. The thinking is that it's better to have them working at a minimum usable level than not at all.

Hope that helps!

Ben Gamari (bgamari) said : #2

Hi Jeff,

Thanks for your reply. I am glad to hear that multitouch will soon be on the grey list.

Thanks for reviewing the scrolling issue. I hope you agree that this should be noted in the certification document.

To be clear, the inability to configure the touchstick independently is due to the lack of driver support, causing the touchstick controller to expose both input devices as a single, generic PS/2 device. Conveying absolute touchpad motion and touchstick events independently requires that the driver place the controller in absolute mode. Once this has been done, the driver can demultiplex the event stream and pass events up two user-space through two separate devices. The Alps driver does this by default in the case of dualpoint devices, as seen on my Latitude D830,

     $ xinput
     ⎡ Virtual core pointer id=2 [master pointer (3)]
     ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
     ⎜ ↳ Microsoft Microsoft® Nano Transceiver v2.0 id=10 [slave pointer (2)]
     ⎜ ↳ Microsoft Microsoft® Nano Transceiver v2.0 id=11 [slave pointer (2)]
     ⎜ ↳ DualPoint Stick id=13 [slave pointer (2)]
     ⎜ ↳ AlpsPS/2 ALPS DualPoint TouchPad id=14 [slave pointer (2)]

These two devices can be configured completely independently.

I should note that since I initially reported this, I have done some reverse engineering of the protocol. After several sleepless nights I have a patch[1] which allows the kernel's alps driver to configure this device and produce dualpoint multitouch events. Hopefully I'll have some time to clean this up soon, at which point I'll submit it upstream for merge.


- Ben


Andrea Ratto (andrearatto) said : #3

When I bought this laptop it came with Ubuntu 11.10 preinstalled and I swear I had two fingers scrolling and edge scrolling as well. It was not perfect, but still nice to have.
How did you do it? Was it some customization to the default installation?

Too bad I had to change everything and I cannot check myself...

Jeff Lane (bladernr) said : #4

Andrea: To be honest, I don't know. The pre-install image is different than the stock Ubuntu image. The pre-install images will have various tweaks and other things to enable the hardware to a minimal degree at least. The goal is to ultimately get the fixes that are put into the Pre-Install image into stock Ubuntu, but that process may take one or more releases to complete depending on when a given system was enabled.

Also, if you have installed or upgraded to a later version, you may want to check the mouse/touchpad settings and verify that edge scrolling and/or two finger are not just disabled (just to verify).

In any case, that's a driver function so there's a good chance that the difference between the driver in the 11.10 pre-install image and 12.04 stock are different. Have you tried with 12.10? Even if you don't install 12.10 yet, you could download the ISO, create a bootable USB stick and see if you can enable it within that environment.

Ben Gamari (bgamari) said : #5

On this note, it would be nice if the "pre-installed only" certification would indicate what can be expected to be broken on a stock Ubuntu installation. At least a diff of the vendor-provided image and the stock Ubuntu release would provide an idea of what the vendor had to do to get the hardware working. I understand this increases the effort required for certification testing but it seems more fair to consumers and might provide an incentive for vendors to upstream hardware support quickly where possible.

Kent Baxley (kentb) said : #6

The 11.10 preloads definitely contained a proprietary driver from Alps that enabled all of the nice features. Unfortunately, Alps does not make this driver widely available outside of the preload environment (if at all).

For 'older' Dell Latitudes with Alps touchpads (6420 and older for example), some engineering work was done by Seth Forshee of Canonical to enable things like horizontal and vertical scrolling:

Those vintage of Dell laptops running 12.04 should get the improved Alps support for free.

The 6430, 6530, etc. generation of Dell laptops, however, introduced a different animal that doesn't work with the drivers included in 12.04. It looks like Ben is making some good progress, though.

Andrea Ratto (andrearatto) said : #7

The patch from Ben Gamari activates the touchpad but:
1 it's horrible code
2 the touchpad is quite "jumpy" when you use it.

The driver from Alps is better, but the scrolling is really slow and so far there is no known download link for it.
I don't think that a laptop should be certified if there is no public online access to proprietary drivers.

Ben Gamari (bgamari) said : #8

Yes, my patch needs a thorough cleaning before it can be considered for merge. I wish there were more time in the day but sadly other projects have taken precedence so far. Moreover, as Andrea mentioned, there is evidence that the protocol implementation isn't quite right. I, too, have observed that the touchpad isn't terribly pleasant to use. This will take some time to look into but it's still on my list of things to do. Hopefully time will become more readily available in the next few weeks.

DeeJay (wmbldonwannabe) said : #9

I am completely befuddled and overwhelmed with frustration by this feedback discussion. This has to be the most ridiculous thing I have ever heard!! The only "good" news is that I'm not the only one experiencing this. "...and not something we'd even test for. As long as they work, it'll pass. The thinking is that it's better to have them working at a minimum usable level than not at all."????!!!! REALLY??!! How is that considered "working"????!!!!

I've owned IBM Thinkpads and Dell laptops for over 15 years and I have NEVER had an issue with disabling the touchpad/touchstick!! And thanks to Ben for his trying to provide some code to try and override this fiasco of a pathetic joke, but even then I had to say WTH & WTF????!!!! "....Once this has been done, the driver can demultiplex the event stream and pass events up two user-space through two separate devices."????!!!!

I'm so outdone. Please just tell me when some kind of software passes the black/grey/fucshia/pink lists!!

The bug for the touchpad is quite solved, see this report:
A patch has been released, and it works fine on mine.

Can you help with this problem?

Provide an answer of your own, or ask Ben Gamari for more information if necessary.

To post a message you must log in.