Ubuntu Certification Programme

Feedback on the Asus Eee PC 1215P

Asked by alessandro silli on 2012-03-18

My brand new netbook 1215p doesn't turn on.There is no support for ubuntu o.s.: i think it's not working because i've tried the f9 button to see how the recover will work in ubuntu...but there's not such thing as recover, it seems.Then i've read in ubuntu forums that ubuntu is not partitioned..it means that all my data are lost forever?I'm very upset.
So this is everything.The netbook worked, than i've tried f9, than it didn't work anymore.Any suggestions?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu-Certification Edit question
Assignee:
Jeff Lane Edit question
Solved by:
alessandro silli
Solved:
2012-03-31
Last query:
2012-03-31
Last reply:
2012-03-30
Jeff Lane (bladernr) said : #1

I'm sorry you're having trouble with your 1215P. Can you tell me a few things?

1: What do you mean by "My brand new netbook 1215p doesn't turn on"? Does it power on? Or does it fail to boot?

2: "There is no support for ubuntu o.s" Do you mean there's no bootloader? Or do you mean you try to boot from the bootloader and Ubuntu does not completely boot?

3: " i've tried the f9 button to see how the recover will work in ubuntu...but there's not such thing as recover, it seems" I'm not familiar wtih this... are you referring to the "Recovery Partition" that some computer makers use to allow you to re-install the OS in emergencies? If you have installed Ubuntu from ISO image, you will NOT have this partition. The Recovery partition is installed/created by the computer manufacturer and is not something that Ubuntu would provide during installation.

4: Now, Please try to tell me, in detail, what exactly you did, start to finish:
 - Did this machine come pre-installed with Ubuntu?
 - Did you upgrade?
 - Did it come with Windows and you then installed Ubuntu instead?
 - Did you do a side-by-side (multi-boot) install, or did you delete the partitions on the disk (wiping out windows)?
 - What version of Ubuntu did you install or are you trying to run right now?

The Asus EeePC 1215P is only certified for a pre-installed version of Ubuntu provided by Asus. That leads me to believe that you may have purchased this machine with that pre-installed versionn of Ubuntu 10.10 and have tried to either upgrade or re-installed with a later, unsupported version of Ubuntu.

That system also failed Certification for 11.04 and 11.10 but it failed for reasons other than not booting. So the system SHOULD be bootable using one of those, however, it is NOT certified for those, thus your experience may not be the same.

alessandro silli (krimin-ale) said : #2

Hello Jeff, thank you for your help, and sorry for my terrible english. The problem is now solved, i've just boot with another os via usb key, to reinstall the grub menu.
It seems that, although the pc is selled with ubuntu, it's made to work with windows...when i buy it i thought that it 100% made for ubuntu.That's why, while i was disappointed descovering that the only "ubuntu-optimized-hardware" was the sticker in the front of the netbook, i've tried various shortcuts that was meant for windows, because i had a windows user manual for my ubuntu netbook!One of those shortcut was f9, that erase mbr for restoring a non-existent windows partition.There are the swap, the ext3 where the ubuntu preinstalled is, and a tiny and dangerous (for silly people like me) and useless 1.3gb fat32 partition to restore windows.
Well..i guess that what i just tell you answer all of your questions, at least the relevant ones.
About the Certification: now i have in dual boot linux mint 12, based on the 11.10, and it seems to me to better recognize the machine hardware than natty, dispite the fact that i cant seem to use asus repository for oneiric (if you have any suggestion on how to do it, please feel free to explain me what to do, i can't figure it out); there are just a few minor issues, nothing more..and for instance the multitouch works, not as it does in windows, but better than in the preinstalled os.

Jeff Lane (bladernr) said : #3

Awesome! and You don't need to apologize. I only ask very specific questions because with the language barrier, sometimes specific questions help explain problems better.

I'm glad you have solved the problem, and I've learned something new from your experience as well. I live in the US, and very few companies sell Linux or Ubuntu pre-installed, so I've always done my own installations, usually wiping the hard drives in the process.

If you have Mint based on Oneiric running, that's a good sign. I know we've tried Oneiric (11.10) on the 1215P system and it did, as I mentioned before, fail certification, but that was due to issues that involve usability, not booting. So I would not expect a 100% usable system, but one that should work "well enough" until the problems can be addressed. I've actually been looking at the US version of the 1215P myself as a replacement for my old Lenovo netbook, so I have great interest in people's experience with Ubuntu on those systems.

I was not aware that they include some sort of Windows recovery partition on a machine that's supposed to be pre-installed. Did you order it pre-installed, or did you get it with Windows and then install Linux afterwards?

If you are comfortable in re-installing Mint or Ubuntu from scratch and will NEVER try re-installing from that weird recovery partition, you can probably format the entire hard disk and use that. OR, you can be safe and leave that partition intact just in case.

As for using the repositories, you could try adding the official Ubuntu repositories for Oneiric instead.

This is based on Lucid, but in theory, you should be able to just substitute oneiric for lucid in the commands listed:
https://help.ubuntu.com/community/Repositories/Ubuntu

Also, this site should help you as well:
http://repogen.simplylinux.ch/