Feedback on the Dell Inspiron 17R (N7110)

Asked by Peter Würtz on 2012-02-11

The Dell Inspiron 17R is listed as "certified", suggesting that this machine works well with ubuntu. In fact, it does not. It is rather horrible to work with.

First of all, the system does not boot at all using the standard 11.10 or the current 12.04 live cd/usb. All you will see is a black screen with no further information. After some investigation, there seems to be a problem with acpi (http://en.community.dell.com/support-forums/software-os/f/3525/p/19424751/20002498.aspx#20002498). The workaround is to disable acpi completely.

Second, my mobile-broadband usb device only works when plugged into the one usb 2.0 port. Using one of the usb 3.0 ports won't work, and you will see errors when looking at dmesg. This seems to be a common unresolved problem with some usb 3.0 controllers, as others seem to have trouble with their devices as well (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/647973).

Another problem is the Nvidia Optimus configuration. There is no support for linux, so you cannot use the Inspiron's nvidia graphics card. There is some experimental workaround called "Bumblebee", but I had no luck getting it to work.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2012-02-11
Last reply:
2012-02-19
Ara Pulido (ara) said : #1

Hello Peter,

I am sorry you had a bad experience running Ubuntu on your laptop.

Manufactures release different configurations with the same brand model, and that is the reason why we list the components that are part of the configurations we are certifying.

Currently we certify two configurations:

 * http://www.ubuntu.com/certification/hardware/201101-6957/components
 * http://www.ubuntu.com/certification/hardware/201101-6983/components

None of them had the acpi problem you mentioned. Also, none of these configurations is an Optimus configuration, they just had the Intel graphics. The reason is that, as you mentioned, there is no Optimus support in Linux.

zurich (wbadenhorst) said : #2

Peter states - 'There is no support for linux, so you cannot use the Inspiron's nvidia graphics card' but I see from this link: http://news.softpedia.com/news/New-Nvidia-Linux-Driver-Supports-Ubuntu-11-04-196264.shtml
that the Nvidia GeForce 525m is supported for Linux. Would someone be able to explain this to me?

Would someone be able to give an opinion on whether disabling acpi is a big thing or not?

At the end of the day I am going to run Ubuntu (or some variation). I am trying to determine if I should go through the work of returning the computer and finding one that might play nicer (but I don't really have the experience to formulate an opinion on it)

Peter Würtz (pwuertz) said : #3

Add not working Headphone jack to the list. Bug 931721

limes (spocony-panczenista) said : #4

Ubuntu 12.10
Dell Inspiron N7110
GeForce 525M
BIOS A13
--
Fan noise problem [resolved]
Optimus card problem [resolved]
--
Install fresh Ubuntu. When booting from a USB press F6 and set acpi = off

During the installation, turn off internet access
After installing the system, turn on the internet and type:

sudo add-apt-repository ppa:bumblebee/stable
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get --purge remove xserver-xorg-video-nouveau
sudo reboot
sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic
sudo reboot

Allow installations and updates all other system components.
sudo apt-get upgrade

Only this method worked out after three days of hard work and more than a dozen attempts.

It is worth to mention another problem. Ubuntu on the Dell Inspiron N7110 will not start if there is any USB device connected during boot. To avoid this problem:

sudo pico /etc/default/grub

find:

GRUB_CMDLINE_LINUX_DEFAULT = "quiet splash"

and replace:

GRUB_CMDLINE_LINUX_DEFAULT = "quiet splash pci=noacpi"

sudo update-grub

This way you can rebooting Ubuntu with USB devices connected BUT this method is forbidden when you want to use Bumblebee
Read -> https://github.com/Bumblebee-Project/Bumblebee/wiki/Troubleshooting
"Be sure that your kernel boot parameters do not contain on of the options noacpi, pci=noacpi, acpi=off"

Can you help with this problem?

Provide an answer of your own, or ask Peter Würtz for more information if necessary.

To post a message you must log in.