Feedback on the Lenovo Thinkpad T420

Asked by Noorul Ameen on 2011-10-30

I am able to install ubuntu 11.04 lenovo T420 32-bit image successfully. So far all driver works fine without any issue.

But I have a problem on update/upgrade of packages. Even I am not able to install "Adobe Flash" plugin for firefox.
"Ubuntu Software Centre" keeps on searching and never ends.

How can I install/update/upgrade the packages?

- Ameen

Question information

English Edit question
Ubuntu-Certification Edit question
No assignee Edit question
Solved by:
Noorul Ameen
Last query:
Last reply:
Tomodachi (tomodachi) said : #1

in the program "software sources"
check the box "software restricted by copyright or legal issues (multiverse)"
then you should be able to find it in the app-store

personally I use google-chrome as my web-browser
they package their own version of flash and are therefore more up-to-date with flash and upgrades than ubuntus flash. - do download it

Noorul Ameen (noorulameen) said : #2

I installed ubuntu image from

I couldn't find "software sources" option to configure under "Ubuntu Software One".

Also, I tried to install chrome browser from deb package and got the following error.
root@ubuntu:~/Downloads# dpkg --install google-chrome-stable_current_i386.deb
(Reading database ... 129589 files and directories currently installed.)
Preparing to replace google-chrome-stable 15.0.874.106-r107270 (using google-chrome-stable_current_i386.deb) ...
Unpacking replacement google-chrome-stable ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable depends on libnspr4-0d (>= 4.7.3-0ubuntu1~); however:
  Package libnspr4-0d is not installed.
 google-chrome-stable depends on libnss3-1d (>= 3.12.3); however:
  Package libnss3-1d is not installed.
 google-chrome-stable depends on libcurl3; however:
  Package libcurl3 is not installed.
dpkg: error processing google-chrome-stable (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for man-db ...
Processing triggers for python-support ...
Errors were encountered while processing:

Noorul Ameen (noorulameen) said : #3


Doing the following command solved all the installation/update problem.

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update