Feedback on the Dell PowerEdge R300

Asked by Hans on 2011-09-06

Hi!

I just tried to install ubuntu-10.04.3-server-amd64.iso several times on a Dell Power Edge R300 Server - and failed. After Install, the operating system is not found ("Missing opearting system") and I wonder if it´s a raid controller issue. I also tried different ways of partitioning, also a small ext2 partition on the beginning of the harddisk for /boot to prevent bootloader issues on the 750GB RAID1 harddrive. But still OS is not found.

I did not find exactly the same problem on internet forums but lots of grub problems regarding R300 and recent Ubuntu Server releases. So I wonder that R300 is "certified" from Ubuntu??

Here is some information about my R300 system:

1x 2,5 GHz QuadCore Xeon X3323
8 GB RAM
LSI SAS1068E PCI-Express Fusion-MPT SAS Controller (rev08)ls

Best,

  Hans

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Solved by:
Hans
Solved:
2011-09-07
Last query:
2011-09-07
Last reply:
2011-09-06
Jeff Lane (bladernr) said : #1

Hi,

I'm not sure what the issue here is, though my guess would be a RAID issue of some sort. Out of curiosity, what is your exact RAID setup?

The system we tested has two SAS hard disks in a RAID 0 config using the same controller you have and I just installed 10.04.3 this morning on that system and did a full update to the latest SRUs as well.

Also, the error you're getting "Missing operating system" sounds more like a BIOS message than it does a grub message (e.g. the BIOS is telling you it can't find a boot loader") so it's entirely possible that your installation is completing successfully but there's another issue at a deeper level. It's also entirely possible that the grub install is failing at the end of the install for some reason.

Be that as it may, I'm unable to reproduce this issue on our R300. You can compare components in our system to yours by going here:
http://www.ubuntu.com/certification/hardware/201003-5448/components

Hans (listacc) said : #2

Hi,

yes I wonder why it´s not working. Before trying Ubuntu, we had an OpenSUSE on the server that installed without any problem.

It´s a simple RAID-1 with two 750GB SATA disks. Here are parts of the controller menu:

-----------------------------------------------------------------

LSI Logic Config Utility For Dell SAS 6 v6.14.10.00 (2007.09.29)
Adapter Properties -- SAS1068E

 Adapter SAS1068E
 PCI Addtess(Bus/Dev/Func) 05 :00 :00
 MPT Firmware Revision 0.20.48.00-IR
 SAS Address 5001EC90:DEDDC300
 NVDATA Version 28.06
 Status Enabled
 Boot Order 0
 Boot Support [Enabled BIOS & OS]

RAID Properties

 Array 1 of 1
 Identifier Dell VIRTUAL DISK 1028
 Type Integrated Mirror
 Scan Order 0
 Size(MB) 714302
 Status Optimal

Slot Device Identifier RAID Hot Drive Pred Size
Num Disk Spr Status Fail (MB)
0 ATA Hitachi HUA72107A74A Yes No Primary No 715404
1 ATA Hitachi HUA72107A74A Yes No Secondary No 715404

SAS Topology -- SAS1068E
       Device Identifier Device
SAS1068E(05:00:00) Info
|_ Enclosure Direct Attach Devices Controller
  |_ Bay 0 RAID Physical Disk SATA
  |_ Bay 1 RAID Physical Disk SATA
|_ IM VOL Dell VIRTUAL DISK 1028
  |_ Phy 0 ATA Hitachi HUA72107A74A RAID
  |_ Phy 1 ATA Hitachi HUA72107A74A RAID

Advanced Adapter Properties -- SAS1068E

  IO Port Address EC00
  Chip Revision ID 08

  Advanced Device Properties
    NCQ [Enabled]

Phy Properties -- SAS1068E

 PHY 0 (1st of 8 PHYs)
 SAS Port 0
 Connector Name Unknown
 Connector Location Unknown
 Connector Type Unknown
 Link Status Enabled, 3.0 Gbps
 Discovery Status 00000000

 Device Identifier ATA Hitachi HUA72107A74A
 Scan Order 9
 Device Information SATA
 SAS Address 12210000:00000000

-----------------------------------------------------------------

I will have a closer look at the GRUB installation then.

Thank you for your help.

  Hans

Hans (listacc) said : #3

Hi,

I found out that the DRAC5 remote management card caused the trouble.

In the card you can activate virtual flash drives that appear on the system as a harddrive. This messed up the drive letters and the system is not booting when virtual media are accessible in the boot menu. I Did not find out if this makes BIOS or grub fail, but with a SuperGrub2 disk I can boot in the installed system.

Installing a system remote by DRAC5 card or directly at side failed when having logged in the DRAC card; however, when I took the server to my workplace, not connected to the DRAC card, and with virtual flash deactivated in the card´s menu, it installed and booted without any problem.

BTW, the pipe symbol is missing in the DRAC5 virtual console. Seems to be designed mostly for Windows OS.

Again, thank you for your help!

  Hans

Jeff Lane (bladernr) said : #4

Glad it worked out... That's interesting though. I'm not terribly familiar with the DRAC5 but I'm assuming it's the Dell equivalent to IBM's RSA modules. I am quite familiar with those, though I never encountered one that had externally visible onboard storage.

At a guess, I'd imagine those virtual flash drives you mention are for hosting hypervisors for virtualization setups so that you can run your hypervisor off a small dedicatd flash module and store your VMs on large arrays inside or outside the host machine.

In any case, it seems that you could probably do some manual partitioning and either bypass the flash on your DRAC 5 module, or incorporate it (use it for primary OS storage and use hard disks for data storage and /home, /var, etc)

Good luck!