Feedback on the Dell Precision M4600

Asked by kluessi on 2011-07-28

Hi,

I'm working with the M4600 and Ubuntu 11.04-64bit with Bios Rev A04. I have some problems with the cpu frequency scaling. I got the Intel i7-2720QM, which is supposed to run at 2.2Ghz without Intel Turbo Boost.

The problem is the cpu speed is limited by the bios to 1.8 Ghz.

I'm using a Dell Advanced E-Port Docking station. Yesterday when I undocked the Laptop as it was in use, I could monitor the scaling_max_freq going up from 800Mhz to 1.8Ghz in 100Mhz steps.

As I docked the laptop back in the scaling_max_freq changed to 2.2Ghz and I could monitor with turbostat and i7z that the frequency could be reached and by putting some load on the cpu Intel Turbo Boost kicks in and cpu reaches speeds up to 3.3Ghz.

After I rebooted the system everything went back to the bios limit of 1.8Ghz. I tried again to undock and dock the notebook but nothing changed.

I also tried this without the dock but still the same problem. Can somebody help me please?

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
*****************
    1800000
****************
cat /sys/devices/system/cpu/cpu0/cpufreq/bios_limit
****************
    1800000
****************
cat /proc/cpuinfo
****************************************
    processor : 0
    vendor_id : GenuineIntel
    cpu family : 6
    model : 42
    model name : Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz
    stepping : 7
    cpu MHz : 800.000
    cache size : 6144 KB
    physical id : 0
    siblings : 8
    core id : 0
    cpu cores : 4
    apicid : 0
    initial apicid : 0
    fpu : yes
    fpu_exception : yes
    cpuid level : 13
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 x2apic popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
    bogomips : 4390.92
    clflush size : 64
    cache_alignment : 64
    address sizes : 36 bits physical, 48 bits virtual
    power management:
*********************************

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
*********************************
    2201000 2200000 2000000 1900000 1800000 1700000 1600000 1500000 1400000 1300000 1200000 1100000 1000000 900000 800000
*********************************

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver
******************************
    acpi-cpufreq
******************************

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-28
Last reply:
2011-08-02
Jeff Lane (bladernr) said : #1

Unfortunately, the M4600 is not certified for Ubuntu 11.04. It is only certified currently for pre-installs of 10.10 as sold by Dell in certain locations.

However, I think this is valid issue so I am going to convert this to a bug for you. Please help with that bug to see if we can get this sorted out for you.

Can you help with this problem?

Provide an answer of your own, or ask kluessi for more information if necessary.

To post a message you must log in.