Lenovo Thinkpad Edge E220s

Asked by Qaxi on 2011-06-03
Ara Pulido (ara) said : #1

And that's why this system is not certified with Ubuntu 11.04
This system is only certified for pre-installed versions of Ubuntu 10.10, this is, if the system was sold with Ubuntu on it pre-installed.

Sos Oganessian (sos-u) said : #2

Except now it is certified for 12.04 _64 bit_, and considering:

this: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/990938

and this: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/994968

and this: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1001786

The cerification should now probably be revoked until lenovo patches the bios. Also I do not believe the e220s ever came with 10.04 preinstalled, and least a google search doesn't come up with anything, so I am, to say the least, skeptical.

Maybe without the first bug(which is 64 bit only) but considering it say "Canonical works closely with Lenovo to certify Ubuntu on a range of their hardware.

The following are all Certified. More and more devices are being added with each release, so don't forget to check this page regularly."

I highly doubt it should be for either.

Sos,

We did not observe the problem with the brightness key causing the system to hang when the system was certified, so I'd like to suggest you post the output of 'lspci -v' on your system, so we can check the hardware config is the same.

In saying a system comes pre-installed with Ubuntu, this reflects the fact that a special image has been created for this system and provided to the OEM to use as they see fit. The pre-installed system may only be available in a few markets and for a certain period of time. This is entirely at the OEMs discretion.

Thanks,

Meant to set to needs info

Greg Vallande (gvallande) said : #5

Hello,

   I have tested the Lenovo Edge 220s with the following (see below) to validate the Brightness keys do not cause an issue or the system to lock up. As requested can you please include the output of 'lspci -v' on your system. Thank you!

12.04 / (3.2.0-23) - Works as expected, no lockups, no hanging system.
12.04+updates / (3.2.0-27) - Works as expected, no lockups, no hanging system.

-/- g

Sos Oganessian (sos-u) said : #6

Just to re-clarify what I said in the first post, the issue is with the 64 bit version only, which is the version in the certified here: http://www.ubuntu.com/certification/hardware/201103-7427/

I only say so because no one has specified the arch of their test setups, just the version(12.04). The bug is not present in the i686 version (which I am currently running). I've got a live cd if you need further testing, but the issue happens on every linux distro, its likely an upstream behavior in the kernel( I think it might even be fixed 3.5). I am not trying to blame Ubuntu for it, just that the certification is an incorrect one. The lspci -v as well as a whole host of other debugging metrics are listed in the original bug report I filled, here is the lspci output from it:

https://launchpadlibrarian.net/103515072/Lspci.txt

I should also note that the mouse issue is not a small one either, and is likely also an upstream issue. It is present across the board, x86 and x86-64.

Sos Oganessian (sos-u) said : #7

I just realized that the original title of the bug was incorrect(I have since fixed it). I, at the time, had thought I recreated the bug on the x32 setup, but that only ever happened on the live CD, and only the once, and now after months of running it of the harddisk without issue, I am thinking that it was a fluke on x32 or something else live cd related perhaps.

Sos,

I don't understand what you mean by 'no-one has specified the arch of their test setups' - if you're referring to the comment from Greg, that is the same system as was tested to issue the certification and the image used is indeed the amd64 one. From looking at the lspci it seems the systems are pretty similar, so this is puzzling me a bit.

@Greg, can I ask you to check if either of the other two issues mentioned appear? This might give us some clue if there is something different about the two systems.

Greg Vallande (gvallande) said : #9

Hello,

   Also one other thing that would pose most helpful, Can you please include the BIOS version you are running on the Lenovo e220s? Thanks!

-/- g

Sos Oganessian (sos-u) said : #10

Brandon,

That is what I mean. What more can I provide you guys that is not in the bug report?

Greg,

To answer your question about the BIOS: all of them. I bought this machine pretty at launch (my battery reports first charge in 05/2011.) And with each BIOS release I do a live cd check(usually a fresh install just in case) of the 64 bit install to see if it has solved any problems. The bug has persisted from day I got. I've tried 12.04, 11.10 11.04 and fedora 15, 16, and 17. No go.

Sos Oganessian (sos-u) said : #11

12.10 update:

improved:
microphone and speakers/headphones connector sensing works.

unchanged:
mouse still hangs for 5/10 second on start.
x64 builds still hangs when pressing the brightness keys

regressions:
on the x86 build the brightness OSD no longer shows, the buttons still work.

Jeff Lane (bladernr) said : #12

Hi, could you please update the bugs (if you haven't already) with the info from your experience with 12.10? And if those regressions you listed are new, please file new bugs for them.

Thanks!

Can you help with this problem?

Provide an answer of your own, or ask Qaxi for more information if necessary.

To post a message you must log in.