Feedback on the Lenovo Thinkpad T420

Asked by Sajith T S on 2011-05-01

The 64 bit installer crashes on Thinkpad T420, while files are being copied to the disk -- I ended ends up on the console with a kernel crash log. Also, wireless doesn't work. Do I have to run Ubuntu 32-bit?

Thanks,
Sajith.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Solved by:
Jeff Lane
Solved:
2011-05-01
Last query:
2011-05-01
Last reply:
2011-05-01
Best Jeff Lane (bladernr) said : #1

The ThinkPad T420 is certified for Pre-Install from Lenovo only... see the FAQ link for more info on that.

To answer your more immediate questions, I just tried doing full Natty testing on the T420 and was unable to certify the system for Natty. The Pre-Install custom engineering wasn't finished in time to make it into Natty. The hope is that at some point in the next few months, that work will make it into a Natty update at which time you should be able to install on the T420 without issue.

Also, the fixes to get Ubuntu working on the T420 should make it into Oneiric in the fall (11.10)
FAQ #1523: “Where can I find a Pre-install/Manufacturer image”.

Sajith T S (sajith.sasidharan) said : #2

Thank you. I however could find no option to select Ubuntu as the Operating System at the time of customizing the laptop at Lenovo's web store.

I can confirm that Ubuntu 11.04 32-bit works on T420. One major headache is, NetworkManager seems to be having trouble connecting to my school's WPA/WPA2 wireless network. It has an Realtek RTL8188CE wifi adaptor, and uses the rtl8192ce driver.

Sajith T S (sajith.sasidharan) said : #3

Thanks Jeff Lane, that solved my question.