How to run core apps on device?

Asked by William Penney on 2013-03-23

I've successfully install this app on my device however I can't seem to run it. I've tried the following after ubuntu_chroot shell:
qmlscene --desktop_file_hint=/usr/share/applications/qmlscene.desktop ubuntu-calendar-app.qml
but this device just locks up and I need to reboot it.

Any help would be greatly appreciated.

Regards,

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Calendar App Edit question
Assignee:
No assignee Edit question
Solved by:
Neo Nengrong Qu
Solved:
2013-03-24
Last query:
2013-03-24
Last reply:
2013-03-24
Best Neo Nengrong Qu (qunengrong) said : #1

@William Penney (ColMustard)
maybe the best way to run it is to use qtcreator;
firstly, import the app by open the calendar.qmlprojectcalendar.qmlproject file in qtcreator with Ctrl+O;
secondly , just use Ctrl+F12, to send files to your device and see it's running;

by the way, you may noticed that there is log message in the qtcreator , and you may get to run it in the device's command line as:
bash -ic 'qmlscene /home/phablet/ubuntu-calendar-app/calendar.qml --desktop_file_hint=/home/phablet/ubuntu-calendar-app/calendar.desktop'

Neo Nengrong Qu (qunengrong) said : #2

sorry for the mistake, i was using middle key to paste , so it was pasted twice, the correct file to open in qtcreator is :
calendar.qmlproject

William Penney (wgpenney) said : #3

I also found that if I install it from the repository onto the device this works:

qmlscene --desktop_file_hint=/usr/share/applications/ubuntu-calendar-app.desktop /usr/share/ubuntu-calendar-app/ubuntu-calendar-app.qml

Thanks

Neo Nengrong Qu (qunengrong) said : #4

hi William, which repository do you mean ? i tried to install the app (in my nexus 4 phone) with command:
sudo apt-get install ubuntu-calendar-app
but with no luck, 'E: Unable to locate package ubuntu-calendar-app'; only may laptop (upgraded to 13.04)have the package;
i've added the ppa from “Ubuntu Touch Core Apps Drivers” , but i'm not sure whether these packages contains only scripts and are suitable for arm;
Any tips shared will be appreciated;
Regards;

William Penney (wgpenney) said : #5

Try the following in terminal with your device connected via usb:

adb root
adb shell
sudo add-apt-repository ppa:ubuntu-touch-coreapps-drivers/daily
sudo apt-get udpate

sudo apt-get install ubuntu-calendar-app