Windows XP Media Center version 2005, Ubuntu latest version, and Solaris 10

Asked by Milardo on 2007-03-09

i am knew to ubuntu 7.10.i have installed it with wubi,when i try to bootup i get busybox.is it posible to skip this and go to desk top.i was hoping to change to ubuntu but i think it will be to hard for me.

Question information

Language:
English Edit question
Status:
Solved
For:
Bootloader Manager Edit question
Assignee:
No assignee Edit question
Solved by:
Milardo
Solved:
2007-03-11
Last query:
2007-03-11
Last reply:
2007-03-10
Leandro Gómez (leogg) said : #1

Hi Milardo!

You can edit the menu.lst with your favorite text editor:

gksudo gedit /boot/grub/menu.lst

Regards,

Leo

Milardo (zerosportslegacy) said : #2

In which os do I do that and what edit command do i type in thanks.

Leandro Gómez (leogg) said : #3

From the Ubuntu terminal. Just type:

gksudo gedit /boot/grub/menu.lst

Add the new entries, save and reboot.

If you have any doubts, maybe you can show me the output of that file before you edit it...

Milardo (zerosportslegacy) said : #4

What ubuntu terminal is that? You mean just type that line and save and reboot? In which order should I install os? I am thinking windows, then solaris, then ubuntu? Because then I will have all of them installed and be able to boot up windows or ubuntu and then I can make the above changes?

Leandro Gómez (leogg) said : #5

Ah! ok... sorry... my mistake... I thought you've already had the three OS installed.

You should install Windows first. You can find more info here:

https://help.ubuntu.com/community/WindowsDualBoot

Hope this helped!

Leo

Milardo (zerosportslegacy) said : #6

I don't have a problem with getting windows to boot it is just either solaris 10 or ubuntu each one disables the other boot depending on which is installled first yes. Because of the grub start up is different.

Leandro Gómez (leogg) said : #7

Ok, have you already installed win+ubuntu in dual boot?

Leandro Gómez (leogg) said : #8

Hi again, Milardo!

I've googled a bit and found this:

http://paraz.com/15/repartitioning-for-ubuntu-and-solaris-take-1/
http://paraz.com/16/repartitioning-for-ubuntu-and-solaris-take-2/

Let me know if it worked for you...

Regards,

Milardo (zerosportslegacy) said : #9

Hi, followed the links and they don't seem to list any answers to my problem seems it didn't work out for the person, I have installed windows, then ubuntu, and then solaris 10. I don't think I can make solaris 10 boot from ubuntu grub because grub file seems to be read only. However solaris grub file is editable I am trying something I found out on the web...

Leandro Gómez (leogg) said : #10

The problem booting the hard drive-installed Solaris from DVD, in my previous post, was just a typo (boot_archive, not boot-archive)

I decided to repartition the extended partition and get rid of the extra 2 GB. I created a FAT32 partition at the normal maximum, 32 GB, for file storage. I reinstalled Ubuntu, giving it 20 GB. Then, I used the Solaris DVD to boot into the hard drive image, edited the menu.lst, and used installgrub to update.

Milardo (zerosportslegacy) said : #11

Not sure if that can help me but here is the link to a possible answer that I am working on.

http://www.sun.com/bigadmin/features/articles/multiboot_laptop.html

Ralph Janke (txwikinger) said : #12

I think, currently you change by reset the boot flag between partitions. The boot flag should always remain on the partition with grub on it, and then grub shoudl chainload the OS you wish after you selected it

Best Milardo (zerosportslegacy) said : #13

Here is what I did.

Windows XP, Solaris 10 (Unix) and Ubuntu 6.10 (Linux) Multiple Boot!

I just was looking for some alternate operating systems to use besides Windows XP and came across Solaris 10 (Unix) and Ubuntu 6.10 (Linux), both free. I decided that I wanted to create partitions on my hard drive for all three and be able to boot any that I wanted to. I had trouble at first because I could only have either Solaris 10 or Ubuntu 6.10 with Windows XP, not all three because of the conflicting grub boot programs of Solaris 10 and Ubuntu 6.10. After some testing I got it to work. I got Windows XP Media Center version 2005 with update rollup 2, Solaris 10, and Ubuntu 6.10 all able to boot. Here is what I did. First I have a 500gb Western Digital hard drive so this is great for the above. Anyways I first installed Windows XP Media Center version 2005. I formatted and partitioned the hard drive to about 419993 NTFS 4kb with Data Lifeguard Tools 11.2 which came with my drive. I use this because it is super fast. It is probably possible to download from the western digital website for free and use it with a non western digital drive. Because my drive is so big it takes XP a super long time to format it. That is why I use the Data Lifeguard Tools. After installing XP and whatever necessary to install it, next for Ubuntu 6.10. I use the ubuntu-6.10-desktop-i386.iso on cd. Boot up with it. I have to enter special commands on the boot up screen because my custom computer needs it. To do this I have to press F6 right away and the end of the command sentence type noapic nolapic. Press enter and I get to the try out first desktop. I double clicked install went through the prompts, strange the pacific time is off, and when I got to the partition part I choose to manually edit partitions. Next I clicked on the unallocated space and clicked on the new partition button. I chose around 40gb first primary partition kept it ext3. You need to make a second partition because it says it needs one for swap. I made that 300mb primary partition ext3 as it says it needs to be at least 256mb. I finalized this and got the screen where you choose mounts. / is the 40gb one, swap is 300mb. Finalized this and here is the critical part you see a screen that shows what is going to happen and you see something that says grub hd0. I changed that to hd0,1. This will prevent Solaris 10 from conflicting with Ubuntu grub and you won't get a message saying linux fdisk is in the way. Finalized and it installed. After restart, you should not be able to boot ubuntu it should directly go back to windows. That is what happened for me. Put in Solaris 10 cd and boot from it chose solaris, solaris interactive, default video display press enter. (Make sure to pay attention to installation otherwise at least for me it won't install correctly) Go through the prompts when you get to the part where it says default no/yes I chose no and I allocated rest of hard drive for solaris 10. Modify the mounts I chose 300 for swap and 100 for the /export/home thing and the rest for /. Finalized this and it installs. Make sure to pay attention to the installation prompts. Finished installing rebooted and it opened the optical drive I took out disc closed the drive and waited for it to boot up the login screen. You might expect to see at boot screen for all the OS to show up but you just see solaris and windows. I had to enter something in the solaris 10 grub menu to enable to see Ubuntu boot. Anyways, next I needed to type in root as username (that is what it said to do in help), then my chosen password. Note that when you type the password it will not show anything but blank just type and enter. I choose the java desktop next wait for the registration screen click later and next. Clicked on this computer and file system, boot, grub, menu.1st. At the bottom I typed

title Ubuntu, kernel 2.6.17-10-generic
      root (hd0,1)
      chainloader +1

Saved the file and restarted the computer. When I got to the boot screen for the OS I see a new selection for Ubuntu, kernel 2.5.17-10-generic. Selected that and it took me to the Ubuntu grub menu with windows! So that is how I got all three operating systems, Windows XP, Solaris 10, and Ubuntu 6.10 installed and able to choose which one to boot. I also tested to see if the other OS would still select and yes it worked. Hope this helps for anybody that wants the a windows os, a linux os and a unix os on one hard drive!