Starting graphic mode after Joomla Appliance installation in virtual box.

Asked by Houdi

I followed the joomla appliance tutorial both written and video and got to the point where my Joomla virtual machine boots up from hard disk and the dialogue box which describes the IP addresses to access the network and has an "advanced menu" option. Neither the video or the written tutorial explicitly explains how to exit the console and to bring up the web browser. When I select the advanced menu and exit the console, I end up at the command line. Its been a long time since I have dealt with linux so I am a neophyte. However, after logging on as root, the startx command does not work. I tried the pwd and ls commands with no display of directories or files in root. What are the next steps to bring up the browser and connect to the web, webmin and PHP. Thank You.

Question information

English Edit question
TurnKey Linux Edit question
No assignee Edit question
Solved by:
Alon Swartz
Last query:
Last reply:
Revision history for this message
Best Alon Swartz (alonswartz) said :

TurnKey software appliances are designed to be run as a server and accessed/configured remotely, from another computer. Joomla, Webmin and the other web applications are supposed to be accessed from a web browser (e.g., Firefox or Internet Explorer) running on another computer.

In other words, to make this very plain, you would put the URL displayed in the appliance's configuration console into the browser's address bar.

Refer to this forum [1] post which should answer your question in more detail.

Just to be clear, startx does not "work" because no graphical interface is installed on the appliances (see [1] for an explanation of why). /root seems to be empty but does infact have hidden files and folders (ls -la). You should refer to [2] to get an overview on how to browse files and folders if your interested, but not required to use the TurnKey appliances.

Hope the above helps.


Revision history for this message
Houdi (houdi) said :

Thank you for the help. I had previously tried my browser on the host computer but with no success. I had also reconfigured the networking to the bridging device. After getting your advice, I went back to the host computer web and it worked. Thank You.

Revision history for this message
Houdi (houdi) said :

Thanks Alon Swartz, that solved my question.