Drupal6 updates fail

Asked by arjuk1 on 2009-06-30

Cannot run apt-get on Drupal6 appliance

I could only get the ubuntu updates to work by editing the sources.list file and changing it to deb http://gb.archive.ubuntu.com......etc
Turnkeylinux name resolves to 97.107.134.22
hosts command seems sensible
Any ideas?
partial screen dump follows:
__________________________________________
root@drupal6:~# apt-get update
Hit http://gb.archive.ubuntu.com hardy-security Release.gpg
Hit http://gb.archive.ubuntu.com hardy Release.gpg
Hit http://gb.archive.ubuntu.com hardy-updates Release.gpg
Hit http://gb.archive.ubuntu.com hardy-security Release
Hit http://gb.archive.ubuntu.com hardy Release
Hit http://gb.archive.ubuntu.com hardy-updates Release
Hit http://gb.archive.ubuntu.com hardy-security/main Packages
Hit http://gb.archive.ubuntu.com hardy-security/universe Packages
Hit http://gb.archive.ubuntu.com hardy/main Packages
Hit http://gb.archive.ubuntu.com hardy/universe Packages
Hit http://gb.archive.ubuntu.com hardy-updates/main Packages
Hit http://gb.archive.ubuntu.com hardy-updates/universe Packages
Ign http://archive.turnkeylinux.org hardy-security Release.gpg
Ign http://archive.turnkeylinux.org hardy Release.gpg
Ign http://archive.turnkeylinux.org hardy-security Release
Ign http://archive.turnkeylinux.org hardy Release
Err http://archive.turnkeylinux.org hardy-security/main Packages
  404 Not Found
Err http://archive.turnkeylinux.org hardy-security/universe Packages
  404 Not Found
Err http://archive.turnkeylinux.org hardy/main Packages
  404 Not Found
Err http://archive.turnkeylinux.org hardy/universe Packages
  404 Not Found
W: Failed to fetch http://archive.turnkeylinux.org/ubuntu/dists/hardy-security/main/binary-i386/Packages.gz 404 Not Found

W: Failed to fetch http://archive.turnkeylinux.org/ubuntu/dists/hardy-security/universe/binary-i386/Packages.gz 404 Not Found

W: Failed to fetch http://archive.turnkeylinux.org/ubuntu/dists/hardy/main/binary-i386/Packages.gz 404 Not Found

W: Failed to fetch http://archive.turnkeylinux.org/ubuntu/dists/hardy/universe/binary-i386/Packages.gz 404 Not Found

E: Some index files failed to download, they have been ignored, or old ones used instead.

Cheers
ANdy J

Question information

Language:
English Edit question
Status:
Solved
For:
TurnKey Linux Edit question
Assignee:
No assignee Edit question
Solved by:
arjuk1
Solved:
2009-07-01
Last query:
2009-07-01
Last reply:
2009-06-30
Alon Swartz (alonswartz) said : #1

I just checked that archive.turnkeylinux.org resolves correctly from several locations using different nameservers and everything seems fine.

I am going to venture and say that you have a DNS mis-configuration.
What nameservers are you using (ie. /etc/resolv.conf)?

arjuk1 (ajackson47) said : #2

Alon,
Yep I can get turnkeylinux to resolve as well, it just fails with apt-get

I use internal Windows DNS server, however they go out into the real world for external name resolution
they have turnkeylinux.org in their caches at it point to the valid IP address

I can browse (in windows) to the archives.turnkeylinux.org ,so name resolution must be working

I can Ping archive.turnkeylinux.org from my Drupal server

resolve.conf has my two internal servers as name servers
however I've tried with public DNS and it still fails

Cheers
AJ

Alon Swartz (alonswartz) said : #3

I reread your original post (skimmed it the first time), I was too quick to jump to conclusions, so lets start over...

Did you also get 404 errors for archive.ubuntu.com?

Just a wild guess, but do you have a proxy configured on your network?
If so, you need to tell apt to use it, for example:

/etc/apt/apt.conf.d/80proxy
    Acquire::http::Proxy "http://domain\username:password@proxy:port"

I added "domain" in the above example just incase authentication is done as part of windows domain.
I myself have never tried such a configuration, but it should work.

For more proxy configuration information:
  man apt.conf
  zless /usr/share/doc/apt/examples/configure-index.gz

arjuk1 (ajackson47) said : #4

Thanks very much for your help Alon
It was the proxy thing (although I don't use it on my other Ubuntu server ,however that is only using the gb.archives for ubuntu)

I actually put the following at the end of /etc/bash.bashrc (using Internal IP address of Firewall - and I didn't need the username:passoword bit)

export http_proxy=http://username:<email address hidden>:port/

Andy J

Alon Swartz (alonswartz) said : #5

Great to hear it!