Problem trying to install mediawiki turnkey

Asked by Stephane Poirier on 2009-04-20

Ok, so I created a VM using Microsoft's virtual PC. I set it up with 1024MB RAM, and loaded the mediawiki ISO in the virtual DVD drive. I set up the boot order of the virtual machine so that hard drive is first, then CD as instructed in the installation tutorial. When I boot up the VM, I get the initial screen that gives me the option to 1) Launch Live CD, 2) Install to Hard Drive or 3) Boot from first hard drive. I select the Install to Hard Drive option. The VM then reboots and takes me back to this screen. I've verified that the VM is in fact set to boot from HD first. It is. I've tried selecting to boot from first hard drive (3rd option). It just hangs. I've unmounted the ISO and tried rebooting. It hangs. Any ideas. Just for fun I'm downloading the ISO again, in case it's corrupted, but I suspect that if it was corrupted it simply wouldn't boot up, but I'm trying it anyway. Anybody have any other advice?

Question information

Language:
English Edit question
Status:
Answered
For:
TurnKey Linux Edit question
Assignee:
No assignee Edit question
Last query:
2009-04-20
Last reply:
2009-08-05
Stephane Poirier (spoirier) said : #1

I downloaded the ISO again (turnkey-mediawiki-2009.04-hardy-x86.iso) to make sure it was good. I have the same problem. Just to add a litte info... when the computer reboots, it displays a bunch of text on the screen really fast, so it's hard to make out what's going on, but if it's helpful, I can try capturing screenshots from the virtual machine. Thanks for any help you might be able to provide.

Liraz (liraz-siri) said : #2

Hey Stephane, this sounds like a bug in Microsoft's Virtual PC. Perhaps support Ubuntu is not high on their todo list. You can try looking for a workaround by experimenting with boot options (in the boot loader screen) and configuration of the VM. Other then that I suggest you try a different virtualization platform. We recommend VirtualBox, which is available for your platform and is free.

Caben (turnkeylinux) said : #3

I'm not sure if it's fair to point fingers in either direction actually. This is a problem that was introduced with Ubuntu 7, which defaults the video to 24 bit (previous versions apparently had a different default). Virtual PC doesn't support 24 bit though, only 16 bit. With the standard install of Ubuntu 7 and higher, it's possible to change to "Safe graphics mode" by hitting F4 at the setup screen and complete the install without any trouble. Unfortunately, with the Turnkey install, only "Normal" mode is supported. Being new to Turnkey, I don't know my way around here too well yet, but hopefully someone from the core team sees this or some friendly forum member can bring it to their attention.

Can you help with this problem?

Provide an answer of your own, or ask Stephane Poirier for more information if necessary.

To post a message you must log in.