rails apt-get update fails

Asked by thor42


following the description at http://www.turnkeylinux.org/docs/rails/deploying-tracks-application the following error occurs(live system started inside VirtualBox 2.1.0 at XP-SP2 host) after enteruing the first command: 'apt-get update'

Get: ...
Ign ...
Get: 17 ...
Fetched 1939kB in 11s (166kB/s)
W: GPG error: http://archive.ubuntu.com hardy-update Release:The following signatures were invalid: BADSIG 40976EAF427D05B5 Ubuntu Archive Automatic Signing Key <email address hidden>
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy-security/main/binary-i386/Packages.bz2 Hash Sum mismatch
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy-security/universe/binary-i386/Packages.bz2 Hash Sum mismatch
E: Some index files failed to download, they have been ignored, or old ones used instead.

How can this be avoided/solved?

Question information

English Edit question
TurnKey Linux Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
thor42 (volkerloges42) said :

The given application URL is no longer available. I assume that this URL might work:

Revision history for this message
Liraz (liraz-siri) said :

I can't reproduce this on my end, but try the following:

rm /var/lib/apt/lists/*
apt-get update

Revision history for this message
thor42 (volkerloges42) said :

AI did "rm /var/lib/apt/lists/*" and "rm /var/lib/apt/lists/partial/*" and afterwards the "apt-get update" works.