How can I use the footswitch?

Asked by Werner Reichmann

They say it is possible to use a footswitch to start and pause the audio ( Unfortunately, the footswitch does not work. Do you have any experiences with this footswitch? Or any other ideas make it run?
I use Ubuntu 11.10. Maybe the Unity-environment makes problems?
Best, Werner

Question information

English Edit question
Transcribe Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Frederik Elwert (frederik-elwert) said :

I am running this footswitch with Ubuntu 10.04, but I think it should also run with 11.10. The switch identifies itself as a USB keyboard which only has two keys: One key event is triggered when pressing the switch, one when releasing it.

To use the switch with Transcribe, you have to define it as the media control keys for play and pause in the GNOME settings. You should find these settings at »System Settings → Keyboard → Shortcuts → Sound and Media«. You can set the pedal press for play easily by selecting the play shortcut and pressing the pedal. For registering the release as pause, you have to press the pedal before selecting the shortcut, and then release the pedal.

I hope this works.

Revision history for this message
Werner Reichmann (werner-reichmann) said :

Thank you for your answer. I tried the way you described but, unfortunately, it doesn't work. Pressing the footswitch defines as Ctrl+1 and releasing the footswitch defines as Ctrl+2.

Surprisingly, when I press Ctrl+1 on my normal keyboard it works. But pressing the footswitch does not has any consequences.

(I tested the footswitch on a mac and it worked there so it seems not to be a hardware problem.)

Revision history for this message
Frederik Elwert (frederik-elwert) said :

That is strange. I know it definitely works with Ubuntu 10.04, although I think it identifies as F4 and F5 or something like that there. I did not yet test it with 11.10. But I will try to take the pedal home for a day and test with my development machine running Ubuntu 12.04.

Revision history for this message
Frederik Elwert (frederik-elwert) said :

I just tried this with the current test version of Ubuntu 12.04, and there it still works as described. The footswitch fires F4 and F5 key codes. I don’t know if you have a different version of the switch, or if Oneiric behaves weird here. But I am afraid there is nothing I can do on the software side to solve this.

Revision history for this message
Werner Reichmann (werner-reichmann) said :

Frederik, many thanks for your effort!! If I make any progress i'll let you know.

Can you help with this problem?

Provide an answer of your own, or ask Werner Reichmann for more information if necessary.

To post a message you must log in.