Enable touchpad when mouse disconnected

Asked by Oscar Kramer

I see the option to disable the touchpad when a mouse is connected, but what about the reverse? There should be an option to automatically enable touchpad when mouse is disconnected.

Question information

Revision history for this message
solarisfire (sg-solarisfire) said :

This is the behaviour of that function already.

When you connect the mouse the touchpad gets disabled.

Then the touchpad is enabled when the mouse is disconnected.

Just because it doesn't say that, doesn't mean it doesn't do that... It'd be a pretty long menu option if it said "Disable touchpad when mouse plugged, and enable it again when mouse unplugged".

Revision history for this message
solarisfire (sg-solarisfire) said :

But there is a problem with the tray icon not being updated on disconnect. Need a bug report for that.

Revision history for this message
Simon Perkins (simon-perkins) said :

I can confirm this behaviour (tray icon not updated on disconnect) on

touchpad-indicator: 1.0.1-0extras14.04.1-src
ubuntu: 14.04

I also experience #1231873 -- When my laptop suspends and the mouse removed, the touchpad is not enabled upon resume.

Revision history for this message
Oscar Kramer (oscarkramer) said :

@solarisfire -- I did expect the pad to re-enable when I disconnected the mouse but it did not. I can only re-enable by selecting "enable on exit", and exiting touchpad-indicator. I'm running Ubuntu 12.04/64bit

Revision history for this message
Eric Strom (kalayzor) said :

I duplicated this on Ubuntu 16.10. Upon selecting "disable touchpad" from the tray icon, I was (and still am) unable to re-enable the touchpad save by setting the option "enable on exit" and closing touchpad indicator. Similarly, when I restart Touchpad-indicator, it initializes with the touchpad disabled by default and exhibits the same behavior as previously mentioned. I can also plug and remove a mouse and the tray icon will not update and re-enable the touchpad.

Also, perhaps a separate issue, but the "disable touchpad while typing" option did not appear to have any effect, no matter what delay I set it to (500-1000 ms). This option, naturally, doesn't operate at present since the touchpad is now constantly disabled while Touchpad-indicator is on.

Can you help with this problem?

Provide an answer of your own, or ask Oscar Kramer for more information if necessary.

To post a message you must log in.