Touchpad stops working immediately after login 12.04

Asked by Matthew Woodbury on 2012-04-28

I am using a Dell Latitutde E6410. I just updated to 12.04. My user account touchpad stops working after login. I can use the stick mouse in the keyboard (between the G H and B keys). The touchpad does work, however, for the other accounts, after login.

A difference I can think of is that I had touchpad-indicator installed only for this account, before updating (in previous versions of Ubuntu, the Alps touchpad on my machine was not recognized, and so I couldn't disable touchpad while typing, so I used this program to stop it manually). I have since uninstalled the program, but nothing changed.

I have tried using various commands found online, offered as solutions for similar problems (on different models) to restart the touchpad, but none have worked.

Thank you, in advance, for your help.

Question information

Language:
English Edit question
Status:
Answered
For:
Touchpad-indicator Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Try running:

xinput set-int-prop 11 121 8 1

Source:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/601113 #21

Revision history for this message
Matthew Woodbury (mattwoodbury) said :
#2

Thanks for the response.

I am sorry to say this did not work. I even tried restarting afterwards.

Revision history for this message
Matthew Woodbury (mattwoodbury) said :
#3

This is what I get when I do `xinput' alone (I did try the last suggestion with `set-int-prop 11 121 8 1' as well). I don't know if this is helpful.

matthew@matthew-Latitude-E6410:~$ xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ DualPoint Stick id=12 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS DualPoint TouchPad id=13 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_3M id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=14 [slave keyboard (3)]

Revision history for this message
Matthew Woodbury (mattwoodbury) said :
#4

These are the values from a new account where the touchpad is working. I think these are the same.

mattwoodbury@matthew-Latitude-E6410:~$ xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ DualPoint Stick id=12 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS DualPoint TouchPad id=13 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_3M id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=14 [slave keyboard (3)]

Revision history for this message
Sam_ (and-sam) said :
#5

> used this program to stop it manually

Apparently misconfig on user account, did you purge it and verify that no config is left somewhere?
Otherwise I'd reinstall the app and purge it again.

Maybe install this config tool.
http://packages.ubuntu.com/precise/gpointing-device-settings

Revision history for this message
Matthew Woodbury (mattwoodbury) said :
#6

I just tried purging the application, and the purging process seemed to work, but that didn't help. I didn't reinstall and then purge, though. The application is no longer available in the Software Center, and I didn't want to try to find it again on the internet, since the purging process did seem to be successful. Would you recommend trying to find the program so that I could re-purge?

The config tool you mentioned is installed, and I tried playing around with it, but it didn't change anything.

Thanks for your input!

Revision history for this message
Sam_ (and-sam) said :
#7

I've assumed the ppa and already linked your answer (please note 'Overview' on top of this page).
It wasn't available for Precise but in the meantime bug 946955 was fix released.

To purge a ppa it needs ppa-purge.
http://www.webupd8.org/2009/12/remove-ppa-repositories-via-command.html
http://www.webupd8.org/2011/02/touchpad-indicator-now-automatically.html

Again, verify that no config files are left over somewhere.

For the record, release notes say
Added new features:
* autostart
* disable touchpad automatically when plug a mouse

and there is bug 951332 which says it doesn't re-enable touchpad on mouse unplug.

Revision history for this message
Vladimir Prus (vladimir-prus) said :
#8

I observe exactly the same problem, except that I did not install anything called touchpad-indicator. Rather, I went to touchpad settings, switched to two finger scrolling, found that it's not ideal, switched back to edge scrolling, and seems like immediately after that, touchpad stopped working. Only trackstick works. Touchpad works fine under guest session.

Revision history for this message
Vladimir Prus (vladimir-prus) said :
#9

It seems that Fn+F5 re-enables the touchpad again for me, and I can no longer reproduce the behaviour of its getting disabled. So it's probably something different. Sorry for useless commentary.

Revision history for this message
sleepaholic88 (simon-goldin) said :
#10

The following commands worked for me, ymmv:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#11

Then run:

echo "options psmouse proto=imps" | sudo tee /etc/modprobe.d/psmousefix.conf > /dev/null

and it will apply at boot too

Revision history for this message
downward (invisioslice) said :
#12

This works for me, but the touchpad scroll is dead. ACER ONE UBUNTU 12.04 Help please.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#13

All I can suggest is report a bug

Revision history for this message
Alex Burdu (alex.burdu) said :
#14

i'm having the same problem on dell studio xps 1340, ubuntu 12.04 x64. sometines the touchpad just crashes during use for an unknown reason. I managed to work around it with:
sudo modprobe -r psmouse
sudo modprobe psmouse

Revision history for this message
Dan Bergeron (d-bergeron) said :
#15

On a Dell Inspiron Mini 1018 now on Ubuntu 12.04.1 LTS, touchpad used to work on previous Ubuntu version but stopped working sometimes with an update on V12...

Did install Touchpad-Indicator but can't activate touchpad with it.

Did :
sudo modprobe -r psmouse
sudo modprobe psmouse
echo "options psmouse proto=imps" | sudo tee /etc/modprobe.d/psmousefix.conf > /dev/null
reboot

but, still not working.

NOTE : Touchpad works 100% on a Dell Inspiron Mini 1012 we own too.

Somebody can suggest something to do?

Revision history for this message
claudia clemente (clmclaudia84) said :
#16

I've tried these three as listed below:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps
echo "options psmouse proto=imps" | sudo tee /etc/modprobe.d/psmousefix.conf > /dev/null

don't know which one of them but after typed them in terminal launchpad started working again!
Thanks a lot!

Can you help with this problem?

Provide an answer of your own, or ask Matthew Woodbury for more information if necessary.

To post a message you must log in.