No context menu (Windows 7)

Asked by legendarydrew on 2012-10-21

For some reason I no longer get the TortoiseBazaar context menu, in either Windows Explorer or Directory Opus (latest version), in Windows 7. I can see the overlay icons for some of the project folders, and Bazaar Explorer works fine.

I've looked at the other two questions, have uninstalled and reinstalled Bazaar (with TortoiseBZR) several times, but nothing changes. I've also tried adjusting the settings in the tray icon program.

Question information

Language:
English Edit question
Status:
Solved
For:
TortoiseBZR Edit question
Assignee:
No assignee Edit question
Solved by:
legendarydrew
Solved:
2012-11-03
Last query:
2012-11-03
Last reply:
2012-10-23
IWATA Hidetaka (hid-iwata) said : #1

Hi.

.bzr.log is in the my documents folder. Are any errors or warnings printed in this log ?

If no errors or warnings are printed, please try this operations.

1. Open command prompt, and cd to Bazaar install folder.
2. Execute this command.
     tbzrcache.exe --replace
3. Show context menu on the explorer.

And let me know the messages printed on the console.

legendarydrew (headdy) said : #2

I got the following when running tbzrcache.exe --replace and opening the right-click menu in Windows Explorer:

Tue 2012-10-23 19:04:01 +0100
0.260 bazaar version: 2.6b1
0.261 bzr arguments: [u'explorer']
0.271 looking for plugins in C:/Users/D-Mizzy/AppData/Roaming/bazaar/2.0/plugins
0.272 looking for plugins in C:/Program Files (x86)/Bazaar/plugins
1.086 encoding stdout as osutils.get_user_encoding() 'cp1252'
3.796 Deprecated function called
Called from:
  File "bzrlib\lazy_import.pyo", line 200, in _import
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\explorer.py", line 32, in <module>
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\desktop_env.py", line 158, in <module>
5.759 loading explorer extensions for clothes ['Bazaar support', 'Register on Launchpad']
5.779 explorer extensions provided by the colo plugin in C:/Program Files (x86)/Bazaar/plugins/colo/explorer

Tue 2012-10-23 19:04:15 +0100

Tue 2012-10-23 19:04:15 +0100

[10752] 2012-10-23 19:04:16.084 INFO: tbzrcache running...
43.238 opening working tree 'C:/wamp/www/pzl'
[10752] 2012-10-23 19:04:58.622 INFO: checking status of VCSPath(u'C:\\wamp\\www\\pzl')
[10752] 2012-10-23 19:04:58.622 INFO: added cache entry<WtCacheEntry> for VCSPath(u'C:\\wamp\\www\\pzl')
[10752] 2012-10-23 19:04:58.875 INFO: added path to watch VCSPath(u'C:\\wamp\\www\\pzl') - now watching 1 locations
[10752] 2012-10-23 19:04:59.704 ERROR: Error processing remote request
Traceback (most recent call last):
  File "tbzrlib\pipe\server.pyo", line 134, in run_command_loop
  File "tbzrlib\dispatcher.pyo", line 259, in dispatch
  File "tbzrlib\dispatcher.pyo", line 62, in get_file_status
  File "tbzrlib\wtcache.pyo", line 850, in get_status_for_path
  File "tbzrlib\wtcache.pyo", line 801, in _get_cache_for_path
AttributeError: 'NoneType' object has no attribute 'is_file'
78.965 return code 0

legendarydrew (headdy) said : #3

Managed to solve this problem... Something apparently decided to disable a number of context menus without my permission, and I enabled them using a program called ShellExView (http://www.nirsoft.net/utils/shexview.html).