Cannot read notes from Tomboy (Linux).

Asked by Ian M. Stewart on 2014-09-03

I'm trying to use Tomdroid on a Samsung Galaxy S4 Mini. The location for the notes in Tomdroid Settings:Location on SD card: is /storage/emulated/0/tomdroid/
and I've copied all my Linux Tomboy notes into that folder. However, Tomdroid does not show these notes at all, even though the format seems to be the same.

Any note I create in Tomdroid appears in that folder, and I can copy it to the Linux system and Tomboy will open it. However new notes created in Linux Mint Tomboy will not open when copied across to Tomdroid in that folder.

Linux Mint Tomboy 1.15.4
Android Tomdroid 0.7.5

What is going wrong please?

Question information

Language:
English Edit question
Status:
Solved
For:
Tomdroid Edit question
Assignee:
No assignee Edit question
Solved by:
Stefan Hammer
Solved:
2015-04-09
Last query:
2015-04-09
Last reply:
2015-04-08
Ian M. Stewart (ims) said : #1

I created two identical files, one on Tomboy and one on Tomdroid. Both files are copied to the other machine. Tomboy displays both files, Tomdroid only displays the one created on the Android phone.
Both files are nearly identical, but with the following major difference: The Tomdroid file has an erroneous creatinon date.

  <last-change-date>2014-09-03T10:51:29.6447790+01:00</last-change-date>
  <last-metadata-change-date>2014-09-03T10:51:29.6486660+01:00</last-metadata-change-date>
  <create-date>1999-12-31T23:00:00.0000000+00:00</create-date>

The Tomdroid file, if edited within Tomboy and copied back to the phone, does not display the edited changes in Tomdroid. i.e. the file copied back across to the phone is not the one displayed, only the one created within Tomdroid. So where in the phone is Tomdroid storing the file? It is NOT the one in /storage/emulated/0/tomdroid/

Best Stefan Hammer (j-4) said : #2

Hi!

The creation date is a known issue - we do not parese this information and make something up. This will be fixed!

To read and update notes stored on /storage/emulated/0/tomdroid/ you have to setup sync to "sd card" sync and press the sync button. then we will read everything from this folder and write updated notes there.

Did this solve your question?
-Stefan

Ian M. Stewart (ims) said : #3

Thank you so much Stefan. Glad to hear you are still working on this useful software, and that the creation date bug is on the list to be repaired.

Yes, that helped me, and now I can read my Linux created Tomboy notes on my Android phone. Also, I can read tomdroid created notes on my Linux system, but there still appears to be difficulty with this. I have had to set up sync in tomboy, and change the path for that, and it all seems a bit clunky still.

However - all is now good (I think). Now to wrestle with the same problems on my Android tablet!

Ian M. Stewart (ims) said : #4

Thanks Stefan Hammer, that solved my question.