Fail to sync notes

Asked by Luc C. on 2014-02-08

I didn't know where to put that, it might be a bug but I'm not sure.

I have a server with a rainy instance on it, I successfully manage to sync my notes on 2 ubuntu laptop and on 2 android phones but recently I upgraded my motorola defy to cyanogenmod 10.2 and tomdroid won't sync on the device...

I restarted rainy, removed all the SSL keys, I tried again with the other android phone (gingerbread), it works perfectly, but when I try to synnchronize the notes it tells me that the connection to the server failed...

The synchronization works perfectly for all other devices except this one. The server doesn't seem to be the problem.

Any idea how to solve that? (just for information, the server is on the port 8180)

Thanks in advance

Question information

Language:
English Edit question
Status:
Solved
For:
Tomdroid Edit question
Assignee:
No assignee Edit question
Solved by:
Stefan Hammer
Solved:
2014-02-10
Last query:
2014-02-10
Last reply:
2014-02-10
Best Stefan Hammer (j-4) said : #1

HI.

For debugging this issue, you could try to sync via http://, meaning no SSL encryption. If this works, then it is a compatibility issue with the SSL method we use. I already had problems using cyanogenmod before but they fixed it at some point.

It this still does not work, you could build Tomdorid yourself with debugging enabled and connect it to the computer to get the logs.
http://bazaar.launchpad.net/~tomdroid-maintainers/tomdroid/main/view/head:/doc/gather-logs.txt

These logs will tell you more for sure!

Luc C. (lucouluke) said : #2

I'm feeling stupid for not having tried without SSL.

It works well without SSL. So it seems to be a problem with that.

I don't have so much time and I'm not an expert, so I won't try to get the log to see what is wrong. I hope that a future fix of cm will arrange that. I don't like to not use SSL (even if there is nothing critical in my notes...).

Thanks for the help.

Just one more question not directly related: but do you know if we can listen to 2 URLs for one database with a rainy server? (to have SSL connection with some of my devices and no SSL with the last one...)

Luc C. (lucouluke) said : #3

Thanks Stefan Hammer, that solved my question.

Stefan Hammer (j-4) said : #4

I pushed your question upstream to the rainy developer:

https://github.com/Dynalon/Rainy/issues/38