I lost my earlier registration on oneubuntu.com, do I have to reset my android?

Asked by Geoffrey Slocock on 2011-07-01

I have tried un-installing and re-installing tomdroid, but it appears that there is still a stored setting for the earlier one.ubuntu.com registration. This appears to be the reason for the failure to authenticate the server.

Can you point me to a settings file I can remove, so that I can obtain a fresh install and connection for registration to the server?

I googled around for an answer to this one, but with no luck. I feel it must be a common enough issue, too.

The heavy-handed answer is to just re-install the android OS, of course.

Question information

Language:
English Edit question
Status:
Answered
For:
Tomdroid Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-07
Last reply:
2011-07-07
Geoffrey Slocock (gs-k) said : #1

Interestingly I have found evidence that the cause of my problem is more to do with the Android or browser settings than it is to do with the Tomdroid settings. You see the UBUNTU ONE app fails to authenticate my logins; and when I go to register, I am directed to the browser page and am logged in.

I have been doing some googling and it would appear to be difficult to remove the automatic log ins, for specific instances.

Would changing my Ubuntu One password be a work around?

Are there other work around possibilities?

Stefan Hammer (j-4) said : #2

Have you tried going to "Applications -> Manage Applications -> Downloaded -> Tomdroid" and clicking the "Clear data" button?
Removing the Android Device from Ubuntu One connected devices list here https://one.ubuntu.com/account/machines/ will also reset the connection. You must login with your old account details of course.
On the SD card is probably also a folder called "tomdroid" - you can also delete this one.
Tell me, if it works or not!

Geoffrey Slocock (gs-k) said : #3

Thanks jango,

Firstly, I went to Settings > Applications Settings > Manage applications <
> Tomdroid and because, I think, I have an older version of Android I only have the uninstall option, and no "clear data" button.

I have checked https://one.ubuntu.com/account/machines/ again and confirmed that the account is not there. (In a fit of zeal, I had earlier removed it!)

I have checked the SD card again, but could not find a "tomdroid" folder".

I think I will try changing the password at https://one.ubuntu.com/ and see if that produces result. I will get back, of course.

Geoff

Geoffrey Slocock (gs-k) said : #4

You know changing my password didn't seem to work.

Geoff

Stefan Hammer (j-4) said : #5

Which android version do you use? after deleting your device from the ubuntu one website, is tomdroid still synchronising the notes, or does it not work and just doesn't ask you to enter the new account informations?
Maybe I don't get what the actual problem of what you are doing and what you observe. Can you maybe explain step by step, what you do and where the problem occurs? Could also be, that it is a bug...
Jango

Geoffrey Slocock (gs-k) said : #6

Its 2.1-update1. The kernel version is 2.6.29-perf.

Tomdroid does not synchronise for me currently. Although I uninstall and re-install it does not get to the point of authenticating my One.Ubuntu.com account.

On pressing the Tomdroid > Settings > Server button, it asks me to authenticate https://one.ubuntu.com/notes

The response I get is "The connection to the server has failed, please check that the address you entered is correct.

With regard to the possibility of its being a bug, I did find a couple of months ago that I had to do a complete re-install.

Stefan Hammer (j-4) said : #7

Hi!
This problem is tracked as Bug 766225. There people observe the same issue, which eventually disappears again at some point.
There is no need to reinstall tomdroid or your android installation - I am quite sure, it won't fix the problem.

Do I get you right, that the one.ubuntu.com website does not show up at all for authentication and instead this error message is coming?
Are you able to connect to Ubuntu One in the browser and view the notes there?

I think this might be a problem of the Ubuntu One authentication servers and not of your phone. I think it will work, if you try it some time later.

Geoffrey Slocock (gs-k) said : #8

I confirm that the one.ubuntu.com website does not show up at all for authentication, and I just get that error message.

I confirm also that I can get my notes up in the browser by going to one.ubuntu.com/notes.

I agree, the Ubuntu One authentication servers are the likely source of the problem.

I've followed the link to the bug report. And I had noticed it before, too.

So that is an intermittent type of bug!

I have had the issue for a week or so now. But notice that I am getting there by the browser, so that authentication process is working as per this android.

Geoff

Stefan Hammer (j-4) said : #9

I can imagine, that maybe only the process of adding a new device does not work on the servers. So you would be able to access the website, but not to register a new device. You could try to download the new Ubuntu One Files Sync App from the Market and see if you can authenticate there. If the problem is also occurring there, it is clearly a bug in the servers, if not we should post to the bug report to get it fixed in tomdroid.

Geoffrey Slocock (gs-k) said : #10

I have installed "Ubuntu One Files". That takes me to the web page for registration (which works); but -- again -- I cannot log in.

So, yes, I agree that Ubuntu One is not currently permitting new devices to be added to the server.

So we can now mark this issue as resolved. I suppose SOLVED fits the bill, if you see what I mean?

Thanks, jango.

Geoff Slocock

Stefan Hammer (j-4) said : #11

hi!
I am sorry, that we could not really resolve your issue, but we narrowed it down. If you would like to see it fixed, you could file a bug report against Ubuntu One on Launchpad.

You are welcome,
Jango

Geoffrey Slocock (gs-k) said : #12

Hmmmh! That's worth a thought!

I know however that they have had such problems which were not anticipated... I am sure.

I got my first Android phone back in November.

I think I will gear up for filing a report, after I have had a while to think it over and prepare for the action!

Geoff

BTW they are not without issues when it comes to registering Ubuntu boxes as new machines!

Olivier Bilodeau (plaxx) said : #13

Have you tried switching to SD Sync under Tomdroid's settings and switching back to Tomboy Web (with the https://one.ubuntu.com/notes URL)?

AFAIK switching to another sync method clears stored authentication tokens in tomdroid.

Regarding the U1 auth errors (#766225), I think we should add more information about the error in the dialog so we can better diagnose the problem. Maybe it's something on our end.

Geoffrey Slocock (gs-k) said : #14

Well, yes, I have changed over to SD card Sync. And. "THE APPLICATION TOMDROID (PROCESS ORG.TOMDROID) HAS STOPPED UNEXPECTEDLY. PLEASE TRY AGAIN." is the message that pops up. I am not able to get past this blockage.

So that may be significant diagnostic information.

Olivier Bilodeau (plaxx) said : #15

Would it be possible for you to upgrade to android 2.2? There's a report
error feature that would help us identify that crash.

If not, can you give us steps to reproduce? Especially what you did on your
u1 account.

Geoffrey Slocock (gs-k) said : #16

<quote>If not, can you give us steps to reproduce? Especially what you did on your
u1 account.</quote>

My educated (or not) guess is that the token stayed set on the phone after I deleted the earlier working account at u1. And that token is what prevents me from initiating and setting up a new account.

So (and this is only my guess work) it may be possible to include a test for whether a token-OK account functions or not. If not, then maybe some end-user dialog to ask if a you want to set up a new u1 account.

<quote>Would it be possible for you to upgrade to android 2.2? There's a report
error feature that would help us identify that crash.</quote>

I have checked out the manufacturer's site and unfortunately there is no upgrade available.

Geoffrey Slocock (gs-k) said : #17

Is it possible for someone to reproduce the situation of deleting the u1 account and then examining whether the ability to create a new account (initiated from the from the Android) is prevented by this dead-end error message, that I report?

A work around that I haven't yet investigated is creating a new u1 account. That sort of migration might prove to be easy. I have already tried a change of password.

Geoffrey Slocock (gs-k) said : #18

Just to report that I have successfully logged in... I had earlier given up! I know this thread overlapped with <<Authenticating with U1 gives a "please check the address you entered" error on HTC Desire>>

Just to recap, I am using Android 2.1 on an Alcatel 980-T. We earlier thought that there might have been an authentication server issue at UbuntuOne.

I hope this info might be of some help to you guys. I would be interested to know what you know of what more has come been discovered of the root of the issue.

Pi3cH (mr-pedram) said : #19

After removal of U1 Notes WebUI I started to get "The connection to the server has failed, please check that the address you entered is correct".

I tried the following options:
 1.Completely remove Tomdroid and reinstalling
 2. Removing my phone name from the devices list in u1.

I am running Android 2.3, HTC Hero.

Can you help with this problem?

Provide an answer of your own, or ask Geoffrey Slocock for more information if necessary.

To post a message you must log in.