Titania just quits

Asked by Roy Walmsley on 2015-10-01

I have just reinstalled the latest Kubuntu, 15.04, complete with all automatic updates. I then changed the driver to the recommended NVidia 340 driver (I have a GeForce GTX 240 graphics card). Then I downloaded Titania 1.1 and installed it.

I had no issues along the way. I then open the Titania application. I get the mouse icon for a few seconds, and a Titania status bar icon briefly, then nothing. It is as if the application has just closed. There are no messages indicating problems.

These are the only things I have done. No other apps have been installed. No other changes made. I tried rebooting and rerunning Titania. Same end result.

Sorry, I am inexperienced with Linux typed systems, normally being Windows based.

Question information

Language:
English Edit question
Status:
Solved
For:
Titania Edit question
Assignee:
No assignee Edit question
Solved by:
Holger Seelig
Solved:
2015-10-11
Last query:
2015-10-11
Last reply:
2015-10-10
Roy Walmsley (roy-walmsley) said : #1

Hi again,

This morning (Mon 5th October, 0830 UTC) my Kubuntu system automatically applied an update to Titania. I tried opening it again. This time it opened, but all I got was a completely white window with a black bar across the top. There was the icon in the top left corner, and centred text reading "about:home - file:///usr/share/titania/pages/about/home.x3dv - Titania". The cursor had changed to what is presumably the Titania cursor. I could resize the window. And that is all.

Holger Seelig (holger-seelig) said : #2

Please can you reboot your system and then try to start Titania again?

Roy Walmsley (roy-walmsley) said : #3

Holger,

Thanks for your response.

I am starting to think that it may be a problem with my system, rather than your programme. I seem to be having trouble with it once I use the NVidia driver. It is a fairly old hardware system, which I originally used with Vista. I added an additional hard drive and set up a multi-boot system, so that I could play with Linux systems. As it has nothing else installed I was thinking of reinstalling Kubuntu and trying again. Is it necessary to install the NVidia driver? I suspect it is, but will try running Titania initially without it.

Roy

Holger Seelig (holger-seelig) said : #4

Please excuse me, Titania depends on gconf which is standard under plain Ubuntu. I added the neccessary dependencies for gconf to Titania and they will be installed. Under Kubuntu gconf when run first time creates the director .gconf in the home directory but it has the wrong permissions (root). On my test system I have to remove the .gconf director if empty and then reboot and Titania then runs fine. Please try to remove the .gconf directory and restart your system again.

Holger Seelig (holger-seelig) said : #5

Fix commited (titania-trunk).

Best Holger Seelig (holger-seelig) said : #6

Fix released (titania).

Holger Seelig (holger-seelig) said : #7

Changed website slogens to Ā»Titania Is Available For Kubuntu And UbuntuĀ« now.

Roy Walmsley (roy-walmsley) said : #8

Thanks Holger Seelig, that solved my question.

Roy Walmsley (roy-walmsley) said : #9

Holger,

Many thanks for your assistance. Sorry to take such a long time to get back to you.

It seems to be running fine now. After reinstalling Kubuntu and updating, then reloading Titania, it all worked fine. I didn't, at least so far, have to delete the gconf directory.

Regards,

Roy