Write to pipe failed. Upon X3D file open

Asked by Josh on 2015-03-17

When I try to open this file locally. I did download and then try to open.

http://jmvale.esy.es/Deer.x3d

It give this error in status bar

Write to pipe failed.
********************************************************************************
********************************************************************************
Welcome to Titania X3D Browser 0.7.6:
 Compiled at Mar 12 2015 13:20:29
 Current Graphics Renderer
  Name: NVIDIA Corporation GeForce GTX 650/PCIe/SSE2
 OpenGL extension version: 4.5.0 NVIDIA 346.47
 Rendering Properties
  Texture units: 4 / 188
  Max texture size: 16384 × 16384 pixel
  Max lights: 8
  Max clip planes: 8
  Antialiased: true
  Color depth: 32 bits
  Texture memory: 1024 Bytes
 Current Javascript Engine
  Name: Mozilla Foundation SpiderMonkey
  Description: JavaScript-C 1.8.5 2011-03-31
  Version: ECMAv5
 Id: 0x64720e0
********************************************************************************
********************************************************************************

*** The browser is requested to replace the world with 'file:///home/jan/Downloads/freewrl/files/Deer.x3d'.

Any thoughts or suggestions?

Question information

Language:
English Edit question
Status:
Solved
For:
Titania Edit question
Assignee:
No assignee Edit question
Solved by:
Holger Seelig
Solved:
2015-03-23
Last query:
2015-03-23
Last reply:
2015-03-18
Best Holger Seelig (holger-seelig) said : #1

Hello Josh,

Titania does not handle X3D XML Encoded files directly. To load *.x3d files Titania needs the small helper program x3d2vrml, which does the conversion. The tool folder is directly located in the Titania project folder. The tool must be installed properly, and must be in the search path, that Titania can found it.

For instance copy the contents of x3d2vrml/bin to /usr/local/bin and the contents of x3d2vrml/share to /usr/local/share.

Sorry but the make file isn't yet made for such purpose.

Holger Seelig (holger-seelig) said : #2

If you can load the deer you will recognice that it looks not properly. To do so toggle the vertex ordering (ccw).

Josh (s-josh-s) said : #3

I can load the deer now, Thanks.

I am still a newbie at this program, so I am trying to figure the whole thing out and the possibilities.
aka how to "Toggle the vertex ordering (ccw)."

on a side note, I do have a vrml from Pro Engineer that isn't parsing, can I some how attach the file here, or in a bug maybe.

Holger Seelig (holger-seelig) said : #4

You can write a bug report and attach a file there.

Josh (s-josh-s) said : #5

Thanks Holger Seelig, that solved my question.

Holger Seelig (holger-seelig) said : #6

Added Makefile.am to x3dtidy and added install-exec-hock to libtitania-x3d, Titania, and x3dtidy to install required files to share directory and bin.

x3dtidy should now install out of the box.