"Create Baseline" function does not work?

Asked by Lufa on 2008-03-23

H! Thank you for your work!

I have added my /home/ directory (with a lot of photos, 79GB total) and trying to create a snapshot of it.

But pressing "Baseline" actually do nothing - no HDD or CPU activity (program just "think" for a few seconds). No errors appear.

After two days of working (TimeVault is working, I can see info bubles) the Backup directory has 2 GB only.

How can I force it to create a first backup (baseline)? Is such behavior of Baseline button, I currently have, a bug?

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
TimeVault Edit question
Assignee:
No assignee Edit question
Solved by:
Lufa
Solved:
2008-11-06
Last query:
2008-11-06
Last reply:
2008-11-05
Romuald (romu70) said : #1

Same for me Lufa, I never managed it to correctly create the baseline, so I'm going to switch to Flyback.

Lufa (yuriy.smetana) said : #2

Thank you, Romuald.

I mus figure, that for "smaller" directories it worked great.

jgott (jgott) said : #3

I have the same problem here too. The Baseline button does nothing. I noticed that in /etc/timevault.conf there is a Baseline setting that was set to False. So I manually changed it to True and restarted TimeVault. Still nothing. No Baseline of my original files.

Daniel Stiner (danstiner) said : #4

I've always had this problem, and so did not bother to install it on my new computer until just today.
Then I did something I hadn't done before, just clicked Baseline on the default etc directory. The notifier icon correctly changed to have the small clock, which means there are changes in the backup queue. Then I saved and closed my preferences as normal, but the small clock disappeared!
Basically, it seems that you MUST leave the preferences dialog open while working on a baseline. And as far as only handling small numbers of files, I always thought that was also a problem, but right now I am working on a > 183,000 file, 80gb baseline of my /home/ directory, so something must be fixed in the 0.7.5-1_i386 version.
Hopefully I was able to help /someone/ with my random find.

jgott (jgott) said : #5

Thanks Dan. Yes you have to click on the directory entry you want to Baseline (on the Include tab) and then hit the baseline button. Now TimeVault is copying everything.

Daniel Stiner (danstiner) said : #6

So right click on the TimeVault notifer, go to the include tab, click the Add button, select your new directory in the list, click baseline and wait until everything finishes.
The next trick is when you want to enable automated snapshots with more than 8192 directories. This comment from beagle-project.org/Troubleshooting brings some light to our problem with inotify.

The default number of watches is 8192. 16384 is a good value for most people, and 32768 is probably more than enough. Using additional watches does increase the amount of memory used inside the kernel, but increasing the number does not affect the amount of memory if they aren't used.

To change the limit:

sudo echo 16384 > /proc/sys/fs/inotify/max_user_watches

Andrew Stromme (astromme) said : #7

I think the reason why this is happening is because a save event triggers a configuration reload, thus 'resetting' TimeVault and removing the baseline. I'll take a look when I have time.

Johannes H. Jensen (joh) said : #8

I can't get this to work at all. I click the "Baseline" button after adding my home directory. Then I hit save and CPU goes up to 100% but no new files are actually added to the "Pending Snapshots". Then after a while, CPU usage goes down again to 0%. The backup dir only contains a very small portion of my home directory (mostly config/log files which often change).

/var/log/timevault.log reveals a lot of lines like the following:
Aug 12 02:49:59 Snap@1788: 3 processed, 0 taken (3 failed)
Aug 12 02:52:02 Snap@1911: 2 processed, 0 taken (1 failed)

What's wrong? This isn't intended behavior? I'm using the timevault_0.7.5-1_i386.deb from LP.

Vincenzo Ciancia (vincenzo-ml) said : #9

I click on "baseline" while having selected a directory that I wish to back up, and then click on "ok" in the next dialog. I keep the preferences window opened and I "tail -f" the logfile, but *nothing* happens, the dialog disappears and that's all. What can be happening?

Lufa (yuriy.smetana) said : #10

Sorry for offtopic but SBackup is what I was searching for... It just work!