Error: The repository does not have a Release file.

Asked by Michael Timm on 2018-09-08

I get the following error:

E: The repository 'https://launchpad.net/~mjasnik/+archive/ubuntu/ppa bionic Release' does not have a Release file.

...whenever I do an "apt update". As a result I can't install timekpr.

I am on Ubuntu 18.04.1 LTS. It is possible I added the ppa wrong since I am not a very technical Linux user :)

Much love for making the tool, it looks super useful.

Question information

Language:
English Edit question
Status:
Solved
For:
timekpr-revived Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Timm
Solved:
2018-09-10
Last query:
2018-09-10
Last reply:
2018-09-08
Manfred Hampl (m-hampl) said : #1

What is the output of the following commands (to be executed in a terminal window):

uname -a
lsb_release -crid
grep mjasnik /etc/apt/sources.list /etc/apt/sources.list.d/*.list

(I assume that you used a wrong name for the PPA when adding it.)

Michael Timm (emberfiend) said : #2

That last command returned nothing, and after some digging I learned that those files list repositories which apt looks in for programs to install (right?) - so the source I added had vanished.

And then I reflected on all the "how to use Launchpad" articles I read that show you to add ppas in the form ppa:username/ppa.

What I had done was, recognizing the "/ppa" at the end of the "link" given on the main project page (https://launchpad.net/~mjasnik/+archive/ubuntu/ppa), tried to add it as "ppa:https://launchpad.net/~mjasnik/+archive/ubuntu/ppa" following the pattern above.

I assume it got cleaned out of the sources list for being invalid?

Anyway I clicked on the link this time and found the right form to add.

Thanks for taking the time to help me, Manfred. Linux is not beginner-friendly, but it is edifying to learn how things work. :)

Eduards Bezverhijs (mjasnik) said : #3

You should have used this:
sudo add-apt-repository ppa:mjasnik/ppa
It's written on ppa's main page: https://launchpad.net/~mjasnik/+archive/ubuntu/ppa

In Linux there are far more non-user-friendly things than this, hopefully they will not get in Your way ;)