Timekpr service fails to start with status=200/CHDIR

Asked by Beniamin Bronisz on 2020-07-30

As in the summary. Here's the full output from systemctl status:
 timekpr.service - Timekpr daemon service
     Loaded: loaded (/etc/systemd/system/timekpr.service; enabled; vendor preset: enabled)
     Active: activating (auto-restart) (Result: exit-code) since Thu 2020-07-30 09:51:04 CEST; 5s ago
    Process: 28438 ExecStart=/usr/bin/timekprd (code=exited, status=200/CHDIR)
   Main PID: 28438 (code=exited, status=200/CHDIR)

lip 30 09:51:04 thinkpad systemd[1]: timekpr.service: Main process exited, code=exited, status=200/CHDIR
lip 30 09:51:04 thinkpad systemd[1]: timekpr.service: Failed with result 'exit-code'.

As in similar question: it starts when executed sudo timekprd.
The system is Ubuntu 20.04. I think it happened lately after some upgrades but I'm not 100% sure.
/var/log/timekpr.log has nothing when timekprd is started via sysemctl call.

Question information

Language:
English Edit question
Status:
Solved
For:
Timekpr-nExT Edit question
Assignee:
Eduards Bezverhijs Edit question
Solved by:
Eduards Bezverhijs
Solved:
2020-07-30
Last query:
2020-07-30
Last reply:
2020-07-30
Eduards Bezverhijs (mjasnik) said : #1

This seems to be related to changes in file locations for systemd files which was updated accrding to comments from Debian.

Did You reboot the system? If reboot is not possible, let's try this:
sudo systemctl disable timekpr
sudo systemctl daemon-reload
sudo systemctl enable timekpr

Please report back whether this or reboot solves the issue. Also, after reboot / reload, please post the output of:
ls -la /etc/systemd/system/timekpr.service /lib/systemd/system/timekpr.service /etc/systemd/system/multi-user.target.wants/timekpr.service

Beniamin Bronisz (beniaminb) said : #2

I've rebooted. It didn't help.

The output of ls -la:
.rw-r--r-- 287 root 2 maj 19:23 /etc/systemd/system/timekpr.service
.rw-r--r-- 348 root 28 lip 10:04 /lib/systemd/system/timekpr.service
lrwxrwxrwx 35 root 29 lip 21:32 /etc/systemd/system/multi-user.target.wants/timekpr.service -> /etc/systemd/system/timekpr.service

Best Eduards Bezverhijs (mjasnik) said : #3

Ok, I see...

The solution is here:
sudo systemctl disable timekpr
sudo rm /etc/systemd/system/timekpr.service
sudo systemctl daemon-reload
sudo systemctl enable timekpr

Then it should be OK. It's interesting that service file is still in /etc, that's not good and I wonder why.
Additional question: You received an upgrade for standard stable timekpr-next and had this issue, right?

Beniamin Bronisz (beniaminb) said : #4

I can confirm it helped. Thank you for quick solution.

I've checked the logs and it seems that yes, it stopped working after the upgrade on 29th of July.

Beniamin Bronisz (beniaminb) said : #5

Thanks Eduards Bezverhijs, that solved my question.

Eduards Bezverhijs (mjasnik) said : #6

Thanks to You Beniamin, I have found a packaging bug which will be fixed in next release (in coming hours).