trouble launching testdrive after installing kvm

Asked by stlubuntu on 2010-03-10

Testdrive is a really great idea to simplify testing out daily development images in a VM. Thanks so much for sharing this. However, I am struggling with making it work. After reading your blog about testdrive where either virtualbox or KVM is a prerequisite, I opted for KVM. I am running 64-bit Ubuntu 9.10 on an AMD Quad Core Phenom 945 3.0 Ghz processor on a ASUS board with 2 GBs RAM (less shared video mem), so my kernel and processor passed the tests for hardware supported virtualization. I then proceeded to install KVM using Ubuntu tutorials and wikis. One test for successful installation I read is to do an:
$ virsh -c qemu:///system list
Connecting to uri: qemu:///system
 Id Name State
----------------------------------

user@hostname:~$

Seems to have been successful. However, whenever I launch testdrive and attempt to select the first item for 64-bit Lucid VM, I get the error message:

ERROR: You must have either /usr/bin/kvm or /usr/bin/VBoxManage installed.
HINT: Consider installing kvm if your CPU supports VT, or virtualbox-ose...
 egrep "flags.*:.*(svm|vmx)" /proc/cpuinfo && \
   sudo apt-get install kvm || \
   sudo apt-get install virtualbox-ose

Press <enter> to exit...

But I install kvm (and other related packages, too, per the wikis) and I was automatically added to the libvirtd group (full shutdown and reboot as well.)

When I try an sudo apt-get install kvm, it responds with

kvm is already the newest version.

Any advice, suggestions, or recommendations would be appreciated. I have not yet tried virtualbox as I wanted to try to get kvm working.

Thanks so much for sharing this.

Question information

Language:
English Edit question
Status:
Solved
For:
TestDrive Edit question
Assignee:
No assignee Edit question
Solved by:
stlubuntu
Solved:
2010-03-10
Last query:
2010-03-10
Last reply:
stlubuntu (jlrbennett) said : #1

My bad!! This option (SVM) was not enabled in my BIOS. (I did not know this option existed in my BIOS -- new computer.)

Problem solved. It is working fine, now. Thanks. Sorry for the foolishness.