groups disappeared?

Asked by Bill Quayle on 2010-01-04

terminator 0.14

the group functionality has disappeared off of the right-click menu.

where did it go?

Question information

Language:
English Edit question
Status:
Solved
For:
Terminator Edit question
Assignee:
No assignee Edit question
Solved by:
Bill Quayle
Solved:
2010-01-05
Last query:
2010-01-05
Last reply:
2010-01-05

This question was reopened

Chris Jones (cmsj) said : #1

In the terminal titlebars there's a little icon on the left, it's in there :)

Bill Quayle (bill-quayle) said : #2

Thanks Chris Jones, that solved my question.

Bill Quayle (bill-quayle) said : #3

But I guess if you hide title bars by default, that makes it pretty hard to find!

Now it's turned into a request....

"If the title bar is hidden, move the grouping menu to the screen menu..."

(I use terminator extensively in helping to manage many thousands of servers. The ability to multiplex terminal sessions has been indispensable. Thanks so much for this great tool.)

Bill Quayle (bill-quayle) said : #4

Doh! I spoke too soon. Clicking the little title bar icon "Assign to group..." did nothing.
broadcast-all works, though.

I ran debug mode, and didn't see anything that jumped out at me...

RHEL 5.4, python 2.4.3, vte 0.14.

Chris Jones (cmsj) said : #5

Hmm, we do seem to have some oddness if you start making groups before splitting. I would suggest turning the titlebars on and splitting before you start grouping. I'll look into the bugs and what we can do to fix them for the next release.

I am thinking that we might need to make the titlebars enabled all the time because they're very useful for things like the grouping menu, and coping with them sometimes being there and sometimes not is proving quite difficult!

Thanks for your feedback :)

Bill Quayle (bill-quayle) said : #6

I'm back....

Here's the traceback when I click on the "Assign to group..." button.

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/terminatorlib/terminatorterm.py", line 1654, in create_group
    window_x, window_y = self.get_window().get_origin()
AttributeError: 'TerminatorTerm' object has no attribute 'get_window'

I get no popup window, and no way to make or manage groups.

Chris Jones (cmsj) said : #7

This also came up as a bug today and is fixed in the development version. I'll make another release soon to cover this (basically the problem is that we used some functions only found in newer versions of pygtk). Apologies!

Bill Quayle (bill-quayle) said : #8

 I'll hold off for the next version and give that a go, then.

Thanks very much, Chris!