Cannot start with my preferred encoding

Asked by Björn Róbertsson on 2009-08-27

Not far from padys request, however, I want to start with ISO-8859-15 (Extended keyboard support, like € EUR symbol). However, I can only start with UTF-8 or ISO-8859-1.
.config/terminator/config contains encoding=ISO-8859-15
but it will still start in ISO-8859-1

It's a onerous task, to manuall go find the bottom of "Other" encodings :)

Regards,
Björn

Question information

Language:
English Edit question
Status:
Solved
For:
Terminator Edit question
Assignee:
No assignee Edit question
Solved by:
Chris Jones
Solved:
2009-09-02
Last query:
2009-09-02
Last reply:
2009-09-02
Chris Jones (cmsj) said : #1

Which version are you using? With the latest bzr trunk version of Terminator, I am able to set the encoding in the config file and the menu indicates that it is using that encoding.

Björn Róbertsson (bjornr) said : #2

On mið 2.sep 2009 09:55, Chris Jones wrote:
> Your question #81156 on Terminator changed:
> https://answers.edge.launchpad.net/terminator/+question/81156
>
> Status: Open => Needs information
>
> Chris Jones requested for more information:
> Which version are you using? With the latest bzr trunk version of
> Terminator, I am able to set the encoding in the config file and the
> menu indicates that it is using that encoding.
>
>

Ubuntu 9.04 (64 bit), terminator 0.12-2

If I add to .config/terminator/config encoding=ISO-8859-15 then no
encoding is selected and every non-ASCII character is displayed
incorrectly (? mark).

Björn

Chris Jones (cmsj) said : #3

Could you try again with the bzr version please?

bzr branch lp:terminator
cd terminator
./terminator

Björn Róbertsson (bjornr) said : #4

On mið 2.sep 2009 11:51, Chris Jones wrote:
> Your question #81156 on Terminator changed:
> https://answers.edge.launchpad.net/terminator/+question/81156
>
> Status: Open => Needs information
>
> Chris Jones requested for more information:
> Could you try again with the bzr version please?
>
> bzr branch lp:terminator
> cd terminator
> ./terminator
>
>
Yes, encoding is set now, EUR symbol (€) is displayed (not EUR), can
double-click the title... Excellent.

Regards,
Björn

Best Chris Jones (cmsj) said : #5

Fantastic, so then it's either fixed in 0.13, or will be in 0.14 (I think we made some changes in 0.13 so it may well be fixed there already)

Björn Róbertsson (bjornr) said : #6

My selection of encoding (iso8859-15) is now working with .config/terminator/config options.