DPI changes don't seem to apply to titlebar font

Asked by Chris Linstid on 2017-12-15

I switch between a HiDPI display and a normal display pretty regularly and as part of that, I switch my font DPI in a few different ways depending on my desktop environment:

Gnome Shell: Automatic scaling to 2x for HiDPI and 1x for normal, otherwise I don't change font DPI directly. I'm not entirely sure what that changes under the covers.

XFCE: I set the font DPI for GTK apps to 192 for HiDPI and 96 for normal using XFCE's appearance settings (from command line through xfconf-query). I also set dpi via xrandr to the same values.

Regardless of how I change the DPI or scaling in both desktop environments I use, the changes affect the actual terminal font immediately, but they don't seem to affect the font in the titlebar at all, even when fully restarting terminator.

I would love it if the titlebar font would scale along with the terminal font on DPI and scaling changes.

Thanks and please let me know if there's any more information I can provide.

Question information

English Edit question
Terminator Edit question
No assignee Edit question
Solved by:
Stephen Boddy
Last query:
Last reply:

Which version of Terminator you're using? I can only comment on the latest Terminator 1.91 - which is GTK3 - and I'm using Unity desktop. When I switch between HiDPI laptop and LoDPI external monitor, Terminator behaves flawlessly.

Chris Linstid (clinstid) said : #2

Also running terminator 1.91 on debian buster.

clinstid:~/ $ apt-cache policy terminator [20:46:07]
  Installed: 1.91-1
  Candidate: 1.91-1
  Version table:
 *** 1.91-1 750
        750 http://ftp.us.debian.org/debian buster/main amd64 Packages
         50 http://ftp.us.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status
     1.90+bzr-1705-1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages

clinstid:~/ $ lsb_release -a [20:46:33]
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux testing (buster)
Release: testing
Codename: buster

Funny now that I'm playing around with gnome changing display scale, I can't seem to reproduce it. I'll try again on XFCE when I get a chance, it's possible that I was wrong and I was only seeing it there.

Chris Linstid (clinstid) said : #3

Yep, I was able to reproduce it in XFCE.

The commands I use for changing the font DPI in XFCE are:

xrandr --dpi 192
xfconf-query -c xsettings -p /Xft/DPI -s 192

Perhaps I just need to do set one more thing for terminator to pick it up and change the titlebar font size?

I have some screenshots showing it, but I don't see anywhere to attach them to the question.

Yeah, questions don't have attachments. To have them it would need to be a bug instead.

Terminator has literally zero code to respond to a change in DPI. The shell/toolkit takes care of all those details under Unity. I'm at a loss to even give a suggestion. Perhaps raise this as a bug, and hopefully someone who understands what is going on can add enough info to come up with a fix, or even the fix itself.

Chris Linstid (clinstid) said : #5

Thanks Stephen Boddy, that solved my question.