Are words selected when found? Option or bug?

Asked by Mario Mey on 2017-07-18

Why, when I search a word, Terminator finds it but the word is not selected?
The line continging the word appears at top... but somtimes it's difficult to find where is the word in that line...
Is this an option... or a bug?

Question information

English Edit question
Terminator Edit question
No assignee Edit question
Solved by:
Stephen Boddy
Last query:
Last reply:

Neither, it's a limitation carried over from the old gtk2 terminator/libvte and an existing wishlist item. The current code is old and custom and needs updating. The underlying gtk3 libvte widget has builtin search that does highlight the search string, but this requires someone with the necessary knowledge and time to sit down and rewrite it.


Mario Mey (mariomey) said : #2

Thanks for the response, Stephen. I looked at the bug and I saw that you made a patch. Maybe some day, I'll test that patch... if not, I'll wait for a kind soul to finally fix this bug.

And sorry for not searching this issue as a bug. With a little more effort, I would had found the report :D.

Mario Mey (mariomey) said : #3

Thanks Stephen Boddy, that solved my question.