Cool feature gone missing!

Asked by psypher on 2009-02-13

Hi All,

In the version of terminator that was installed in ubuntu hardy the
transparency worked well in a certain way. When you have transparent
terminal turned on terminator would NOT show what app was below it but
transparently show the entire desktop background. That was what i
wanted. I do not want to see the apps below, i want a full screen
terminal, which I can split and still see the full desktop background
below. Apparently transparency was actually broken then and that is why
it was like that. Please could someone add that as a switch.

I re-iterate. I do not want to set a background for terminator. As my
background changes randomly with a script and cannot be integrated with
terminator and when you do turn on backgrounds in terminator and you
split screens then each window has a copy of the background. not very

What will it take to add this switch?


Question information

English Edit question
Terminator Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Chris Jones (cmsj) said : #1

It's not so much that transparency was broken before, it just didn't use the fancy composited effects of newer 3d desktops like Compiz.
My feeling on this is that the enable_real_tranparency setting we already have, should be the switch which controls this. With that set to False it should use the older "fake" transparency where it just shows the desktop image. With it set to True it should use the newer transparency which shows the apps underneath.

Could you use the "Create bug report" link on the left to file this as a bug? I'll mark it as a wishlist and we can probably get that done in the next release.

psypher (psypher246) said : #2

eyes thats exactly what i want. when it's false it should be transparent showing the desktop and true shows apps beneath. truning off transparency completely in gnome-terminal will turn it off making both console apps non-transparent.

I will log as bug, THANK YOU!