Multiple tabs switching graphic glitches

Asked by Nakul Kumar on 2017-03-29

When switching tabs or to any other program and coming back to any tab in terminator, the tab shows either previous screen in current tab like chrome appears instead of terminator content or it shows glitches.
Upon pressing enter key shows screen after cursor or typing command reset works. Another thing that works is when I tried taking screenshot by pressing printscreen button on my laptop. Then glitches went away for a second, but again switching tabs bring them back.

Laptop configuration :
intel i7
16 ram
1 tb hdd

GPU :
$ sudo lshw -C display
  *-display
       description: VGA compatible controller
       product: Sky Lake Integrated Graphics
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:128 memory:d4000000-d4ffffff memory:b0000000-bfffffff ioport:f000(size=64)
  *-display
       description: 3D controller
       product: GK208M [GeForce 920M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:129 memory:d2000000-d2ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:d3000000-d307ffff

Ubuntu 14.04

$ terminator --version
terminator 0.97

Question information

Language:
English Edit question
Status:
Answered
For:
Terminator Edit question
Assignee:
No assignee Edit question
Last query:
2017-03-29
Last reply:
2017-04-05

Hi, You haven't stated what version of Terminator you are using. If you are seeing this in the old gtk2 version (1.0 or less) then you should really upgrade to the gtk3 version (1.90 or higher). If you are still seeing the issue, then this is probably better handled as a bug, not a question.

Oh, and by the way, nice question number :-)

Nakul Kumar (blueboy-neel) said : #3

Ubuntu 14.04

Output of following command :
$ terminator --version
terminator 0.97

Nakul Kumar (blueboy-neel) said : #4

I also noticed the question number just now. Coincidence.

Yeah, that is way, way too old. The code base has moved on, and there's a good chance you will no longer experience the glitches in the newer releases. There were similar sounding complaints in the past, but no-one has raised this as still happening in the newer releases. So my "Solution" for you is to upgrade. We do provide a nightly PPA that is pretty stable as I try very hard not to break it, and I use it myself.

Nakul Kumar (blueboy-neel) said : #6

How can update/get the latest one?

Nakul Kumar (blueboy-neel) said : #7

I did the following mentioned here 'https://launchpad.net/~gnome-terminator/+archive/ubuntu/nightly':

sudo add-apt-repository ppa:gnome-terminator/nightly
sudo apt-get update

the version is now :
$ terminator --version
terminator 1.0

Still facing the same issue

Yeah, you found the old PPA for GTK2. The one you want is this one:

https://code.launchpad.net/~gnome-terminator/+archive/ubuntu/nightly-gtk3

Nakul Kumar (blueboy-neel) said : #9

I tried the one you mentioned but there are some dependency issues :

$ sudo apt-get install terminator
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 terminator : Depends: libvte-2.91-0 but it is not installable
E: Unable to correct problems, you have held broken packages.

Nakul Kumar (blueboy-neel) said : #10

Any updates?

Nakul Kumar (blueboy-neel) said : #11

I downloaded the deb file, and tried installing it using dpkg -i --ignore-depends=libvte-2.91-0 <package>
But unable to start terminator, finally removed it again.
Is there any other way to use terminator?

Ahhh. You're on Trusty, which doesn't have a 2.91 version of libvte. You are probably not going to be able to use the GTK3 version then. It depends on the 2.91 version. So, you would have to update your 14.04 to 16.04. By this point I'd say that 16.04 has had enough time to settle down and become stable. Obviously that's a lot of hassle to use a terminal program though.

Nakul Kumar (blueboy-neel) said : #13

That means I won't be able to use it. BTW why main packages are not updated and one has to use nightlies for terminator?

Because I haven't taken/found the time to sit down and figure out that nook of Launchpad. I intend to do so for 2.0 when it is released.

Can you help with this problem?

Provide an answer of your own, or ask Nakul Kumar for more information if necessary.

To post a message you must log in.