Too easy to close the current shell

Asked by Pawel Veselov on 2016-12-14

I like Terminator. I really do.
However, I've used gnome-terminal before.
My serious problem with Terminator now is that:
a) The location of the "Close" in Terminator's pop-up menu is nearly the same as "Copy" in gnome-terminal
b) There is no way to disable closing terminals
c) There is no way to request that a confirmation is requested before closing

If it were possible to configure either (b) or (c), it would be really great.

Thank you,
  Pawel.

Question information

Language:
English Edit question
Status:
Answered
For:
Terminator Edit question
Assignee:
No assignee Edit question
Last query:
2016-12-16
Last reply:
2016-12-20

a) You think so? For me GT has Copy as second entry, in T the Copy is the first entry and Close is the sixth. I wouldn't say the location is nearly the same.
b/c) We do prompt if you try to close a window. But for either of the options you're talking about, that is a Wishlist item. (Raise a bug marking it as a feature request and I'll turn it into a wishlist item. Note that this is no guarantee that it will get attention from me any time soon - lots of requests, too few contributors.)

Pawel Veselov (pveselov) said : #2

a) I know so :) My GT has, in order: "Open Terminal", "Open Tab" <SEP> "Close Tab" <SEP> "Copy", "Paste" <SEP> "Profiles", "Show Menu Bar". OK, may be because it's mate-terminal?

b) How do I turn on that prompt? If I select "close" from the context menu, the tab, on me, closes immediately without any confirmation or warning.

a) Yup. Probably down to Mate differences. You should add a wishlist item to get a prompt (optional) when closing a terminal.

b) That prompt is only popped up when you close the *window* and it contains more than 1 terminal. It can be disabled by checking a box, and dismissing it. This is a one shot setting though, and cannot be reactivated through the interface. You have to remove a line in the .config/terminator/terminator file. The line:
suppress_multiple_term_dialog = True
needs to be deleted.

Can you help with this problem?

Provide an answer of your own, or ask Pawel Veselov for more information if necessary.

To post a message you must log in.