Terminator: Python-central Dependency Error; Not Sure Why

Asked by dgoodman on 2008-03-19

When trying to install Terminator (.deb file) using Gdebi or dpkg, I get the following error: Dependency is not satisfiable: python-central. I'm not sure why though because I've got the most recent version of python-central. I even reinstalled python-central. This has happened to me on two different Ubuntu 7.10 machines. I'm not sure how to solve the dependency issue since I already have the latest python-central. How do I fix this? Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Terminator Edit question
Assignee:
No assignee Edit question
Solved by:
dgoodman
Solved:
2008-03-19
Last query:
2008-03-19
Last reply:
2008-03-19
Chris Jones (cmsj) said : #1

Where did you get the .deb from?

dgoodman (dgoodman) said : #2

I went to http://packages.ubuntu.com/hardy/terminator and clicked on the "all" link at the bottom, and I have tried this with at least three .deb files from different mirrors.

After further exploration with dpkg, it tells me that I need to have python-central (>= 0.6), and I believe that the most current version of python-central in the Ubuntu Gutsy repositories is 0.5.15ubuntu2. I realize that I am downloading Terminator for Hardy, and not for Gutsy, and that if I download the 0.6 version of python-central that I can probably make it work; not sure though if I might break something by installing the newer version of python-central. The Hardy release is right around the corner, so it won't be a hardship if I have to wait.

Incidentally, I have found that Terminator will run, but can't find any profile values; it runs on default. Also, if I use Synaptic, it tells me that I have 1 broken package. Not a big deal. Sorry if I have waisted anyone's time. Thank you Chris for your response.

Chris Jones (cmsj) said : #3

ah, I've noticed that a few websites have pointed people to the hardy packages repository.
Unfortunately that's not a very good way to get packages for gutsy.

As it happens, we do have a way of helping you - grab the package from our PPA instead:

https://launchpad.net/~gnome-terminator/+archive

Near the bottom you should see two entries, one for gutsy and one for hardy, the gutsy one has a package. Alternatively, you can change the dropdown near the middle from hardy to gutsy and add the apt source to /etc/apt/sources.list :)

dgoodman (dgoodman) said : #4

Chris, thanks so much! I have changed my apt-sources list and have installed the gutsy package for Terminator. Works great, and Synaptic no longer tells me that I have a broken package. Thanks!

This looks like a really nice little application and I think that I'll get a lot of use out of it. Thanks again!

- Darrin